Connexion PCA en admin

Forum concernant les demandes de support pour tout problème d'installation d'un forum phpBB 3.3.x uniquement

Modérateur : Équipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Répondre
Auteur
nicolas88
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 21 avr. 2021 à 15:48

Connexion PCA en admin

Message par nicolas88 »

Bonjour,
Depuis plusieurs jours, je rame pour installer correctement phpBB3.3 sur un synology DS115j.. Il est peu lent mais ce n'est juste que pour le temps de construire le forum et non pour l'héberger à terme..
Voici mon adresse: https://kriyabans.synology.me
J'ai réussi à faire toute l'installation , il passe en revanche sur les pré-requis, ce qui veut peut-être dire qu'il n'y a pas de problème? Mais je ne peux pas vérifier tous les paramètres!!
J'ai préalablement créer un DB au nom de 'forum' sur Mariadb 10.

Voici mon log lors de l'installation:
type db: Mysql
nom d'hôte: 127.0.0.1
port: 3307
db name: forum
user name: root
db m/p: motdepasse
préfixe : phpbb_

Mon seul problème maintenant à résoudre vient du fait que je n'arrive pas à accéder au PCA, même en étant en administrateur.
Synthétiquement:
- Je clique sur PCA
- On me demande de me loguer pour pouvoir devenir admin (alors que j'y suis déjà)
- Je remplis id + m/p
- Ca tourne un petit moment
- Résultat: erreur 500...

De même en cliquant sur 'nouveaux sujets' & 'répondre' à un message..direct l'erreur 500..

J'ai essayé toutes les méthodes trouvées sur le forum, c'est-à-dire:
- enlever dossier 'production' dans /cache
- Mis un point devant cookie_domain dans table php_config avec PHPmyadmin
- Enlever cookie sur Firefox

Ensuite, j'ai lu que certains ont réussi à enlever l'erreur en enlevant le mode Modsec sur le serveur chez l'hébergeur. Pour ma part , je m'héberge sur mon synology et j'ai Apache 2.2 avec Php 7.3 et je ne sais pas comment faire pour enlever ce mode de sécurité sur Apache? Au moins pour essayer.. J'ai fait un compte test comme dans le règlement.. (id:test; mp: ......)
Si vous avez d'autres pistes, je suis preneur... Merci :P
Auteur
nicolas88
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 21 avr. 2021 à 15:48

Connexion PCA en admin

Message par nicolas88 »

Est-ce que quelqu'un pourrait m'aider, ici je suis définitivement bloqué!! Merci beaucoup
Skouat
Resp. Traducteurs
Resp. Traducteurs
Messages : 15245
Enregistré le : 02 avr. 2008 à 20:47
Contact :

Connexion PCA en admin

Message par Skouat »

Bonjour,

Si vous avez un erreur 500, il faudrait voir au niveau du journal des erreurs du service apache.
Si aucune erreur n'est remontée, il faudrait voir s'il est possible de modifier la confirguration du fichier php.ini afin d'activer l'affichage des erreurs.

Concernant modsec, je doute qu'il soit activé (voir activable) sur un Synology.
Auteur
nicolas88
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 21 avr. 2021 à 15:48

Connexion PCA en admin

Message par nicolas88 »

Merci Skouat, je viens de revoir entièrement les permissions et j'avais oublié la récurrence dans les sous-dossiers.
Maintenant, j'ai un autre problème: l'erreur 500 a disparu mais je me retrouve avec une page blanche !! Avec PCA, PCM, répondre, éditer. Tout le reste marche..
J'aimerais vraiment y arriver.. Je cherche tout de même les logs? Ou c'est autre voie maintenant? Merci
Avatar du membre
Sylveretour
Floodeur mature
Floodeur mature
Messages : 1762
Enregistré le : 21 nov. 2017 à 18:24
Localisation : West Coast
Contact :

Connexion PCA en admin

Message par Sylveretour »

Bonjour,

Vu que tu ne connait pas l'administration d'un synology et comme c'est uniquement "juste que pour le temps de construire le forum et non pour l'héberger à terme", tu serait mieux inspiré d'installer un wampserver pour cela...
Skouat
Resp. Traducteurs
Resp. Traducteurs
Messages : 15245
Enregistré le : 02 avr. 2008 à 20:47
Contact :

Connexion PCA en admin

Message par Skouat »

nicolas88 a écrit :
30 avr. 2021 à 15:49
Je cherche tout de même les logs? Ou c'est autre voie maintenant? Merci
Les logs ou une autre voie, il faut à un moment donné commencer la recherche par quelque part ;)
Dans ma précédente réponse j'ai indiqué le journal et aussi évoqué la piste du php.ini.

Mais bon, comme l'a indiqué Sylverleretour, Synology à sa propre mécanique d'administration.
Donc je rejoins sa proposition.
Auteur
nicolas88
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 21 avr. 2021 à 15:48

Connexion PCA en admin

Message par nicolas88 »

Merci pour vos conseils avisés..
Cela fait tout de même 15 ans que j'installe du linux un peu partout.. Et que j'ai un réseau de plusieurs ordinateurs à la maison sur le synology... Et d'autres personnes doivent se connecter à ce futur forum pour le concevoir. C'est pour cela que j'ai choisi mon nas pour le faire même si il est lent car entrée de gamme... C'est vrai que je ne suis jamais rentré par le terminal dans le syno mais tout s'apprend, n'est-ce pas la politique de linux?
Je m'occupe des logs et ce php.ini et je reviens vers vous... Merci
Skouat
Resp. Traducteurs
Resp. Traducteurs
Messages : 15245
Enregistré le : 02 avr. 2008 à 20:47
Contact :

Connexion PCA en admin

Message par Skouat »

Hello,
nicolas88 a écrit :
02 mai 2021 à 11:51
Cela fait tout de même 15 ans que j'installe du linux un peu partout
L'expérience ne signifie rien et ne corrige pas les problèmes, sinon vous ne seriez pas ici à demander de l'aide. ;)
nicolas88 a écrit :
02 mai 2021 à 11:51
Et que j'ai un réseau de plusieurs ordinateurs à la maison sur le synology... Et d'autres personnes doivent se connecter à ce futur forum pour le concevoir.
Si vous avez un tel réseau chez vous, alors Wampserver permettrait de faire tourner le serveur Web sur un machine plus puissante et sans encombre.
Après, une autre alternative consiterai à prendre un hébergeur gratuit pour permettre la configuration initiale du forum.
Et une fois que tout est calé vous le migrez sur votre hébergeur final.
Niveau hébergeur gratuit, et je ne suis pas affilié à eux, vous pouvez aller chez AlwaysData.
Stockage de 100Mo maximum, mais largement suffisant pour ce que vous indiquez.
Et là ca fonctionne sans problème ;)

En tout cas, personnellement, je ne m'embêterai pas avec une machine qui rame et qui semble poser des problèmes d'installation pour phpBB.
Répondre

Retourner vers « Installation »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité