[Réglé] MAJ 3.0.0 vers 3.3.3 : The installer has detected a timeout [Résolu]

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.3.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.3

Modérateur : Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Répondre
Auteur
Richard66
Posteur néophyte
Posteur néophyte
Messages : 38
Enregistré le : 23 avr. 2008 à 16:43

MAJ 3.0.0 vers 3.3.3 : The installer has detected a timeout [Résolu]

Message par Richard66 »

Bonsoir.

Je viens de mettre à jour ma version phpbb3 de la 3.0.0 à la 3.3.3 FR

Tout se passe bien et à la fin : pouf !
The installer detected a timeout

The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.

phpbb/db/migration/data/v32x/fix_user_styles.php
J'avoue que là je suis bloqué.
Google ne donne rien en résultat concret sur ce fichier qui pose problème.

quelqu'un a une idée de ce qui ne va pas ?
Ce qui n'allait pas était simple : lire ! :evil:
Bon sang de dieu. J'ai bien été bête ....
l suffisait de prendre le patch 3.3.3 COMPLET et de suivre les instrutions du panneau de contrôle.
Pas besoin du patch. Plus rapide et plus simple.
Merci de l'attention portée à mon sujet.
Forum sauvé, à jour et fonctionnel :D
Modifié en dernier par Richard66 le 20 mars 2021 à 01:46, modifié 1 fois.

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20985
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: MAJ 3.0.0 vers 3.3.3 : The installer has detected a timeout

Message par Steph »

Salut,

Peux tu préciser comment tu as fais cette mise à jour ?

Auteur
Richard66
Posteur néophyte
Posteur néophyte
Messages : 38
Enregistré le : 23 avr. 2008 à 16:43

Re: MAJ 3.0.0 vers 3.3.3 : The installer has detected a timeout

Message par Richard66 »

Via le ftp en manuel comme toujours. (la fonction auto n'a jamais fonctionné)
J'ai déposé le fichier install comme d'habitude en prenant bien le patch de MAJ de la 3.0.0 vers la 3.3.3 puisque ma version était la 3.0.0.

Durant le processus de MAJ, j'ai eu des fichiers à supprimer, d'autres ont fusionné et à la fin j'ai eu mon archive.
J'ai uploadé les fichiers, recontrôlé la version et à la fin je suis bloqué.

J'ai vérifié à l'instant dans le dossier incriminé et j'ai vu que le fichier fix_user_styles.php était manquant à l'appel ce qui est étrange. Je l'ai rajouté manuellement.

Du coup, j'ai eu une autre erreur :
The installer has detected a timeout
Installing Data: \phpbb\db\migration\data\v32x\add_missing_config.
Je place là aussi le fichier manquant (poruqoi at-il été effacé d'ailleurs ?) et là j'ai désormais ça :
The installer detected a timeout

The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.
Skip “installer.update_filesystem.download_updated_files” task
Skip “installer.update_filesystem.update_files” task
Skip “installer.update_filesystem.show_file_status” task
Skip “installer.update_filesystem.diff_files” task
Skip “installer.update_filesystem.check_task” task
Skip “installer.obtain_data.update_ftp_settings” task
Skip “installer.obtain_data.update_files” task
Skip “installer.obtain_data.file_updater_method” task
Les fichiers sont bien en 3.3.3 mais la base de données est restée bloquée en 3.0.0.
Est-ce que je peux revenir en arrière en faisant patch par patch ou le forum est définitivement foutu ?

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20985
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: MAJ 3.0.0 vers 3.3.3 : The installer has detected a timeout [Résolu]

Message par Steph »

OK, je ne comprends pas vraiment ta manière de faire cette mise à jour ni même comment tu as fait pour palier à la version de PHP obligatoirement en PHP 7.1.3 minimum en phpBB 3.3 et qui ne fonctionne pas pour phpBB 3.0, mais bon.

Il faut faire selon ce tutoriel et les prérequis : Mise à niveau de phpBB 3.2.x vers 3.3.x

C'est pour un passage de 3.2.x a 3.3.x, mais c'est exactement pareil depuis 3.0.x à part que tu ne trouveras pas le répertoire ext dans phpBB 3.0.

D'ailleurs en phpBB 3.0 tu as surement mysql dans ton fichier config.php, il faut désormais mettre mysqli, c'est certainement la source de ton problème en plus de la version de PHP qui doit être à minima la 7.1.3

Auteur
Richard66
Posteur néophyte
Posteur néophyte
Messages : 38
Enregistré le : 23 avr. 2008 à 16:43

Re: MAJ 3.0.0 vers 3.3.3 : The installer has detected a timeout [Résolu]

Message par Richard66 »

En fait, j'avais déjà la version de php en 7.3 chez OVH depuis l'installation en vo de la 3.0.0 il y a un an environ.
My sqli était déjà fait aussi, cela m'avait d'ailleurs posé un gros problème l'an dernier à la migration comme beaucoup.

Hier soir, après une recharge de ma save parce que tout me semblait perdu, j'ai finalement suivi comme mon premier post l'indique désormais les infos données (et à la lettre) par le contrôle de la version dans l'interface.
Donc utiliser le pack complet et non le patch de MAJ qui m'a causé tous ces problèmes en enlevant quelques fichiers et en évitant d'écrire sur les ext.

Cela a marché d'emblée ! :D
En tout cas, merci pour ton intérêt à ma question et ta réponse rapide.
C'est quand tu m'as dit "comment tu l'installes ?" que je me suis penché sur la méthode.
Rien ne sert de courir en effet.

Allez aujourd'hui, je cherche les infos sur le passage en https en espérant que je me plante pas.
Merci encore !

Répondre

Retourner vers « Mises à jour/Conversions »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité