Balises BBCodes inactives

Forum de support pour les questions concernant l'utilisation de phpBB 3.3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur : Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Répondre
Auteur
patrickp78
Posteur néophyte
Posteur néophyte
Messages : 80
Enregistré le : 31 mars 2018 à 18:58

Balises BBCodes inactives

Message par patrickp78 »

Bonjour à tous,
Depuis deux semaines environ, je me suis aperçu que les balises BBCodes (ex : ) ne répondaient plus.
Etant en 3.3.2, j'ai fait la mise à jour en 3.3.3 mais le résultat est le même.

Information complémentaire :
Un post de présentation d'un nouveau membre arrive en anglais, je le modifie pour y ajouter une traduction que je mets en italique :
Texte UK
Traduction FR
Une fois validé, les balises ne fonctionnent pas. Le post reste comme ci-dessus avec les balises apparentes.

Je réponds à ce post :
Réponse UK
Traduction FR
Cette fois, les balises fonctionnent et j'ai bien mon texte en italique.
Le premier post reste avec des balises apparentes.

J'ajoute que les balises des posts précédemment existants fonctionnent toujours.

Si quelqu'un à une idée de l'origine du problème…
Merci d'avance
patrickp78
Version du forum : 3.3.3
Version de PHP : 7.3.27

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20985
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Balises BBCodes inactives

Message par Steph »

Salut,

As-tu fait des modifications au niveau du style ou installé une extension ?

Cela peut probablement venir du style, il faudrait à ce moment-là renvoyer des fichiers "neuf" depuis une archive complète.

Donne-moi un compte test par MP (si j'ai la bonne info qui date de 2018, ton forum n'est pas destiné à un public trop jeune). Si c'est pour un autre forum, alors fourni le lien avec un compte test dans ce sujet.

Auteur
patrickp78
Posteur néophyte
Posteur néophyte
Messages : 80
Enregistré le : 31 mars 2018 à 18:58

Re: Balises BBCodes inactives

Message par patrickp78 »

Merci Steph pour la réponse rapide.
Je vois que tu as bonne mémoire…
Non, je n'ai pas touché aux styles et toutes mes extensions actives sont à jour.
Pour info la mise à jour que j'ai faite hier en 3.3.3 était une archive complète mais comme je l'ai dit la mise à jour n'a pas amélioré le problème.

Je te prépare un compte et te l'envoie en mp.
Merci d'avance pour ton aide,
patrickp78
Version du forum : 3.3.3
Version de PHP : 7.3.27

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20985
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Balises BBCodes inactives

Message par Steph »

patrickp78 a écrit :Je vois que tu as bonne mémoire…
C’est surtout une fiche de suivi :wink:

Bon, j’ai testé avec le compte test et je ne peux reproduire le souci qui est certainement visible avec un accès autre que membre lambda. Est-ce qu’avec le BBCode quote cela fonctionne par hasard ?

Sinon je ne vois pas d’où peut venir ce souci à part peut-être une extension qui agit sur ce point.

Auteur
patrickp78
Posteur néophyte
Posteur néophyte
Messages : 80
Enregistré le : 31 mars 2018 à 18:58

Re: Balises BBCodes inactives

Message par patrickp78 »

Steph,

Si tu reviens sur le site, j'ai ajouté les balises de ton post sur le premier message et celles-ci ne fonctionnent pas.
J'ai ajouté un troisième message en faisant un quote du premier et là, les italiques, gras et soulignés sont correctement pris dans le quote.
Si tu as besoin de plus d'accès, fais-moi signe.
https://drive.google.com/file/d/1CY_GHR ... sp=sharing

Entre temps, je vais désactiver les extensions une par une pour voir s'il y a une incidence.
C'est fait pour les extensions, résultat identique.
patrickp78
Modifié en dernier par patrickp78 le 08 mars 2021 à 14:34, modifié 1 fois.
Version du forum : 3.3.3
Version de PHP : 7.3.27

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20985
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Balises BBCodes inactives

Message par Steph »

Vraiment bizarre ce truc, c’est comme si le parsage ne se faisait pas.
patrickp78 a écrit :la mise à jour que j’ai faite hier en 3.3.3 était une archive complète
Tu as supprimé les anciens fichiers ou tu as écrasé ?

Si la désactivation des extensions ne donne rien et pour être sûr, peux-tu refaire l’opération du point 6 au point 10 de ce tutoriel, mais comme c’est indiqué, c’est-à-dire en supprimant les fichiers du serveur : Mise à niveau de phpBB 3.2.x vers 3.3.x

À conserver tout autre fichier ou répertoire qui n’appartient pas au forum à l’origine. Sinon fais une sauvegarde des fichiers sur ton ordi.

Auteur
patrickp78
Posteur néophyte
Posteur néophyte
Messages : 80
Enregistré le : 31 mars 2018 à 18:58

Re: Balises BBCodes inactives

Message par patrickp78 »

La désactivation des extensions ne donne rien.
Le problème est apparu AVANT que je fasse la mise à jour en 3.3.3

Voici la procédure que j'applique pour les mises à jour (faite à partir des tutos) dis-moi si ok pour toi :
1 - Faire une sauvegarde du Forum
2 - Désactiver les extensions

3 - Télécharger public_html_New à coté de public_html_Actuel
4 - Supprimer config.php, files/, images/, store/ dans public_html_New
5 - Supprimer le contenu de public_html_Actuel SAUF config.php, ext/, files/, images/, store/
6 - Transférer le contenu de public_html_New dans public_html_Actuel SAUF ext/

7 - Activer http://www.xxx.fr/install dans Safari (passer en langue française)
8 - Cliquer sur l’onglet UPDATE et valider
9 - Supprimer le répertoire Install/
10 - Réactiver les extensions une par une (ou faire les mises à jour)
11 - Importer éventuellement les extensions de public_html_New
Modifié en dernier par Steph le 08 mars 2021 à 15:10, modifié 1 fois.
Raison : Suppression du lien
Version du forum : 3.3.3
Version de PHP : 7.3.27

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20985
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Balises BBCodes inactives

Message par Steph »

J'avais lu que c'était déjà avant la mise à jour, cependant c'est la procédure de mise à jour qui m'intéressait et elle me parait pertinente.

Je pense donc à un souci de parsage sans vraiment comprendre ce qui peut poser souci. As-tu testé avec un autre compte qui aurait les mêmes permissions et groupes que toi ? (c'est pour écarter un problème lié au compte, même si je n'y crois pas vraiment)

Auteur
patrickp78
Posteur néophyte
Posteur néophyte
Messages : 80
Enregistré le : 31 mars 2018 à 18:58

Re: Balises BBCodes inactives

Message par patrickp78 »

J'ai essayé avec des comptes similaires, ce n'est pas ça non plus.
patrickp78
Version du forum : 3.3.3
Version de PHP : 7.3.27

Répondre

Retourner vers « Utilisation »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité