[réglé] Mise à jour réussie mais plus de forum

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.3.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.3

Modérateur : Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Auteur
Galaes
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 21 avr. 2020 à 10:13

[réglé] Mise à jour réussie mais plus de forum

Message par Galaes »

Bonjour,
Je viens d'effectuer une mise à jour automatique manuelle. Il me semble avoir respecté toutes les étapes sauf que maintenant à la place du forum je me retrouve avec une page sans code source...
J'ai réinstallé le dossier install qui me dit que le forum est à jour quand je l'ouvre :(
Là je ne vois pas du tout quoi faire, j'espère que quelqu'un saura m'aider...
Modifié en dernier par Galaes le 29 août 2020 à 10:36, modifié 1 fois.

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20973
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Mise à jour réussie mais plus de forum

Message par Steph »

Salut,

Pour commencer je t(invite à supprimer le répertoire production avec tout son contenu, tu le trouveras sur ton FTP dans le répertoire cache.

Pour info, le répertoire production va se recréé tout seul après suppression et c'est normal.

Auteur
Galaes
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 21 avr. 2020 à 10:13

Re: Mise à jour réussie mais plus de forum

Message par Galaes »

Merci pour cette réponse rapide ! Je viens de le faire et pas de changement pour le moment. Ce qui est bizarre c'est que je n'ai même pas de message d'erreur. J'avais remis le répertoire install (qui est le seul à afficher quelque chose), est-ce que je le laisse ou je l'enlève ?
Je n'ai pas non plus accès au PCA

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20973
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Mise à jour réussie mais plus de forum

Message par Steph »

Alors, je te suggère donc de suivre ce tutoriel du point 6 au point 10

Mais avant sauvegarde ton style actuel, et passe en prosilver par défaut (si tu en a un perso).

Auteur
Galaes
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 21 avr. 2020 à 10:13

Re: Mise à jour réussie mais plus de forum

Message par Galaes »

Alors ça me donne ce message : "Aucun répertoire de mise à jour n’a été trouvé, veuillez vous assurer d’avoir transféré les bons fichiers."

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20973
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Mise à jour réussie mais plus de forum

Message par Steph »

J'aurais du préciser "sans le répertoire install"

Supprime le répertoire install et vide a nouveau le cache

Auteur
Galaes
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 21 avr. 2020 à 10:13

Re: Mise à jour réussie mais plus de forum

Message par Galaes »

C'est toujours pareil :?

Avatar du membre
Sylveretour
Floodeur mature
Floodeur mature
Messages : 1748
Enregistré le : 21 nov. 2017 à 18:24
Localisation : West Coast
Contact :

Re: Mise à jour réussie mais plus de forum

Message par Sylveretour »

Bonjour,

C'est donc que tu répète sans cesse la même erreur, la page blanche est signe en général d'un problème de fichiers.
Donc recommence en supprimant d'abord du ftp les dossiers et fichiers du core de phpBB puis envoie les nouveaux, dossier par dossier.
Quelle est l'url du forum ?

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20973
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Mise à jour réussie mais plus de forum

Message par Steph »

Steph a écrit :Alors, je te suggère donc de suivre ce tutoriel du point 6 au point 10
A suivre à la lettre, pas de remplacement de fichiers

Auteur
Galaes
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 21 avr. 2020 à 10:13

Re: Mise à jour réussie mais plus de forum

Message par Galaes »

C'est ce que j'ai l'impression de faire pourtant, j'ai recommencé au moins 4 fois cet après-midi et c'est toujours pareil... L'adresse du forum est forum.fortress-combat.fr

Edit : je remets les bons fichiers là j'ai un message d'erreur mysql parce que je voulais voir ce que ça donnait avec une version antérieure. Je suis un peu désespérée, avec la connexion pourrie que j'ai c'est extrêmement long de télécharger les fichiers sur le serveur et à chaque fois j'ai beau avoir l'impression de respecter le protocole, ça ne marche pas... Il y a un truc que je ne dois pas bien faire mais je ne vois pas quoi :cry:

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20973
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Mise à jour réussie mais plus de forum

Message par Steph »

une extension peut en être également la cause.


Fait cette requête dans phpmyadmin (ou équivalent), cela les désactiveras.

Code : Tout sélectionner

 UPDATE `phpbb_ext` SET `ext_active` = '0' WHERE `phpbb_ext`.`ext_active` = '1';
phpbb_ est à remplacer par ton préfixe.

Ensuite vide le cache du forum par le FTP comme déjà indiqué.

Et au passage, la base de données a été mise à jour en phpBB 3.3.1 donc il ne faut pas mettre des fichiers d’une autre version.

Avatar du membre
stone23
Maître-posteur
Maître-posteur
Messages : 463
Enregistré le : 31 mai 2008 à 13:50
Localisation : Entre la chaise et le clavier
Contact :

Re: Mise à jour réussie mais plus de forum

Message par stone23 »

Salut, je confirme ce que dit Steph car j'ai moi-même galéré pour la mise à jour en 3.3.1.
Il faut suivre la procédure à la lettre, désactiver toutes les extensions et les styles persos s'ils ne sont pas à la bonne version et mettre prosilver par défaut.

J'ai mis quelques infos sur les extensions qui m'ont posé problème dans ce post.
Mon forum
Version forum : 3.3.3
Version php : 8.0.3

Auteur
Galaes
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 21 avr. 2020 à 10:13

Re: Mise à jour réussie mais plus de forum

Message par Galaes »

Oooh merci, merci, merci ! Ca refonctionne :D
J'allais poster que ça ne marchait toujours pas et en lisant ton sujet stone23, je me suis dit qu'il fallait peut-être que je vide à nouveau le cache et cette fois c'est bon !
Donc c'est soit l'extension viglink soit canidev qui faisait planter.

Avatar du membre
Sylveretour
Floodeur mature
Floodeur mature
Messages : 1748
Enregistré le : 21 nov. 2017 à 18:24
Localisation : West Coast
Contact :

Re: Mise à jour réussie mais plus de forum

Message par Sylveretour »

L'extension viglink est d'origine à phpBB et n'est pas en cause.
Par contre, ton style n'est pas du tout mis à jour en 3.3.1 il est en 3.2.8 -> http://forum.fortress-combat.fr/styles/ ... /style.cfg

Avatar du membre
stone23
Maître-posteur
Maître-posteur
Messages : 463
Enregistré le : 31 mai 2008 à 13:50
Localisation : Entre la chaise et le clavier
Contact :

Re: Mise à jour réussie mais plus de forum

Message par stone23 »

Salut,
cBB tchat fait planter le forum, Canidev a publié un correctif. :wink:
Mon forum
Version forum : 3.3.3
Version php : 8.0.3

Répondre

Retourner vers « Mises à jour/Conversions »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité