[Réglé] version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.3.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.3

Modérateur : Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Répondre
Auteur
marc91
Posteur néophyte
Posteur néophyte
Messages : 36
Enregistré le : 20 févr. 2006 à 07:17
Localisation : Essonne 91 sud Ile de France

version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Message par marc91 »

Bonjour

avant de faire la mise à jour de mon forum, je voudrai être certain d’être sous la bonne version du php.

je suis hébergé chez OVH j'ai réglé le php global de mon hébergement sur 7.2 (il était jusqu'à présent en 5.6, en 7.3 le forum ne fonctionne plus)
le fichier .ovhconfing sur la racine est bien en 7.2
cependant quand je vais voir la version php de mon forum dans l'admin , il est resté en 5.6.40

suis-je dans de bonne condition pour faire la mise à jour vers 3.3.0?
ou dois-je intervenir autre part?

Merci pour votre aide
mon forum est hebergé chez OVH
phpBB 3.3.0

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20986
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Message par Steph »

Salut,

Pour phpBB 3.3.0 il faut au minimum une version 7.1.3 de PHP.

Si dans l'administration de ton forum il est indiqué PHP 5.6.40 cela ne fonctionnera pas pour ta mise à niveau.

Auteur
marc91
Posteur néophyte
Posteur néophyte
Messages : 36
Enregistré le : 20 févr. 2006 à 07:17
Localisation : Essonne 91 sud Ile de France

Re: version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Message par marc91 »

Ok Steph c'est bien ce que je pensais mais comment faire pour avoir le bon php dans mon admin?
le fichier .ovhconfing est pourtant bien en 7.2
là je séche.
mon forum est hebergé chez OVH
phpBB 3.3.0

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20986
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Message par Steph »

Pour le coup il faut voir avec OVH, mais il faut le faire via ton espace client lié à ton hébergement.

Auteur
marc91
Posteur néophyte
Posteur néophyte
Messages : 36
Enregistré le : 20 févr. 2006 à 07:17
Localisation : Essonne 91 sud Ile de France

Re: version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Message par marc91 »

Ok je leur pose la question
si j'ai la solution je viendrai la mettre ici
mon forum est hebergé chez OVH
phpBB 3.3.0

Avatar du membre
Sylveretour
Floodeur mature
Floodeur mature
Messages : 1748
Enregistré le : 21 nov. 2017 à 18:24
Localisation : West Coast
Contact :

Re: version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Message par Sylveretour »

Bonjour,

Pour ovh, tout est là concernant le changement de version php -> https://docs.ovh.com/fr/hosting/modifie ... ement-web/

Auteur
marc91
Posteur néophyte
Posteur néophyte
Messages : 36
Enregistré le : 20 févr. 2006 à 07:17
Localisation : Essonne 91 sud Ile de France

Re: version php prérequi avant mise à jour 3.2.9 vers 3.3.0

Message par marc91 »

Bon au fil de mes essais modifications de version de PHP
j'en arrivais à ne plus avoir accès à mon forum en ayant ce message d'erreur que je n'avais pas encore eu quand j'ai posté ma question:

General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

donc j'avais un problème de mysql

je revenais donc au PHP initial le forum re-fonctionnait ouf.

en cherchant un peu (simple copié collé du message d'erreur dans Google) je suis tombé sur un post en Anglais qui préconisait de changer le FICHIER config.php de mon forum.
je ne suis pas un pro de ce genre de manip
mais comme OVH ne répondait pas à mon ticket...

Je me suis lancé.

il fallait modifier la ligne suivante

$dbms = 'mysql';
en
$dbms = 'mysqli'; rajout d'un simple i


j'ai donc rapatrié via filezilla ce fichier que j'ai édité avec dreamweaver
puis uploadé le fichier modifié
et...
ça marche j'ai pu changer le PHP en 7.2

peut-être à garder sous le coude ça pourrait peut être aider quelqu'un je passe le post en réglé.

maintenant j'ai le champ libre pour me lancer dans la Mise à jour version 3.3.0 :D
mon forum est hebergé chez OVH
phpBB 3.3.0

Répondre

Retourner vers « Mises à jour/Conversions »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité