[Réglé] You are running an unsupported PHP version...

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.3.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.3

Modérateur : Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Répondre
Auteur
Diabolo30
Posteur néophyte
Posteur néophyte
Messages : 11
Enregistré le : 14 oct. 2018 à 14:20

You are running an unsupported PHP version...

Message par Diabolo30 »

Bonjour à tous,

Mon forum était en version 2.8, et j'ai voulu le mettre à jour en 2.9.
J'ai sauvegardé la base de donnée, mais je n'ai pas copié les fichiers...
Comme le système nous a proposé la 3.3 au lieu de la 2.9, nous avons installé la 3.3.
Le site a alors affiché le message suivant: "« You are running an unsupported PHP version. Please upgrade to PHP 7.1.3 or higher before trying to install or update to phpBB 3.3 "

Vous pouvez le voir ici: https://diabete-insipide.org/

Je suis alors allée sur le panneau de paramétrage de wistee, et j'ai coché pour la version php 7.3
Mais cela n'a rien changé, le message s'affiche toujours.
Alors nous avons essayé d'installer la 2.9, et ça n’a pas marché.
Nous avons copié à part :
- le fichier config.php
et les répertoires:
-ext
-files
-images.
On a tout effacé sur le serveur, et on a remis la mise à jour 3.3 et ça marche toujours pas. Le message d’erreur est toujours là…

Pouvez vous m'aider, s'il vous plaît?

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20984
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: You are running an unsupported PHP version...

Message par Steph »

Salut,

Le message est très clair, ta version de PHP n'est pas compatible avec ta version de phpBB.

Pour savoir quelle version tourne actuellement sur ton serveur, 2 solutions
  1. La plus simple si ton répertoire install est présent en te rendant à l'URL https://URL_DE_TON_FORUM.com/install/phpinfo.php donc pour toi https://diabete-insipide.org/install/phpinfo.php. On constate d'ailleurs une version PHP 7.0.33 donc ce n'est pas bon.


    Si tu n'as pas le répertoire install, je t'invite à créer un fichier que tu nommes par exemple phpinfo.php avec ceci à l'intérieur

    Code : Tout sélectionner

    <?php
    phpinfo();
    
    Tu places ce fichier à la racine de ton FTP et tu peux accéder à l'URL correspondante pour ton cas, à savoir https://diabete-insipide.org/phpinfo.php
Après changement de version chez ton hébergeur il faut certainement vider le cache du forum en supprimant par FTP le contenu du répertoire cache SAUF les fichiers index.html et .htaccess

Auteur
Diabolo30
Posteur néophyte
Posteur néophyte
Messages : 11
Enregistré le : 14 oct. 2018 à 14:20

Re: You are running an unsupported PHP version...

Message par Diabolo30 »

Re-bonjour,

Merci pour le coup de pouce, mais cela ne fonctionne pas...

Voici ce qui est indiqué chez mon hébergeur: "Current PHP version 7.4", ce qui ne correspond pas à ce qu'indique https://diabete-insipide.org/phpinfo.php, qui indique, comme vous avez dit: PHP Version 7.0.33

Dans mon répertoire cache, il n'y a que les fichiers les fichiers index.html et .htaccess, et aucun autre...

Donc voilà, je ne comprend pas...

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20984
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: You are running an unsupported PHP version...

Message par Steph »

Il faut voir avec l'hébergeur, car la version sur serveur ne correspond pas, nous ne pourrons rien y faire malheureusement à notre niveau.

Avatar du membre
On Stage
Roi des posts
Roi des posts
Messages : 919
Enregistré le : 19 mars 2018 à 16:04
Contact :

Re: You are running an unsupported PHP version...

Message par On Stage »

Salut
Regarde dans le dossier store si tu n'as pas ce fichier install_config.php, si il est présent supprime le et relance la mise à jour
phpBB version: 3.3.3
php version: 8.0.3

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 20984
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: You are running an unsupported PHP version...

Message par Steph »

Cela n'y changera rien du tout, c'est pas la mise a jour qui est en cause, mais la version de PHP qui ne correspond pas aux prérequis pour phpBB 3.3.0

Avatar du membre
On Stage
Roi des posts
Roi des posts
Messages : 919
Enregistré le : 19 mars 2018 à 16:04
Contact :

Re: You are running an unsupported PHP version...

Message par On Stage »

OK
Le problème me faisait penser à une procédure de mise à jour qui bloque sur le premier état de l'erreur, d'où ma suggestion.
phpBB version: 3.3.3
php version: 8.0.3

Auteur
Diabolo30
Posteur néophyte
Posteur néophyte
Messages : 11
Enregistré le : 14 oct. 2018 à 14:20

Re: You are running an unsupported PHP version...

Message par Diabolo30 »

re-bonjour,

Effectivement, le problème venait bien de l'hébergeur.
Le forum est donc de retour, pour le moment, il y a un mélange des versions:
Files Version: 3.3.0
Database version: 3.2.8
et il est en Anglais, mais avec l'aide pas à pas, je pense que nous allons y arriver.

Je vous remercie pour l'aide que vous nous avez apporté ! :D

Répondre

Retourner vers « Mises à jour/Conversions »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité