Avatar

Forum de support pour les questions concernant l'utilisation de phpBB 3.3, les problèmes rencontrés lors de manipulations, de configuration du forum ou de personnalisation autres que les Styles ou les Extensions

Modérateur : Equipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Re: Avatar

Message par ANNIES »

Ovh
Et comment lui expliquer ?

Avatar du membre
Steph
Administrateur
Administrateur
Messages : 21015
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

Re: Avatar

Message par Steph »

Un Up est une relance de sujet en postant deux messages l'un à la suite de l'autre par un même membre en moins de 24h sans qu'il y ait eu de réponse de quelqu'un d'autre, ceci sera le dernier rappel. Ceci peu importe la raison.

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Re: Avatar

Message par ANNIES »

réponse de OVH
"Commentaires de résolution :
Vous nous contactez concernant une erreur d'affichage de votre site.
L'hébergement OVH ne va pas être ici en cause.
Il s'agit d'un dysfonctionnement sur le développement, qui doit être réglé par l'utilisateur.
Il vous faudrait donc, de votre côté, vérifier le pourquoi les avatars ne se chargent plus."


bon il fallait s'y attendre un peu, ne serait ce que si cela venait de OVH je ne serais pas le seul site touché

Enoncé du problème ;
- les avatars, d'un seul coup (sans aucune action de notre part sur le PCA ou les fichiers hébergés) ne s'affichent plus. Il s'affiche le message " avatar du membre" a la place.

Récapitulation des tests et essais faits
- les fichiers images dans le dossier UPLOAD sont bien présent.
Ils s'affichaient. Aujourd'hui ils renvoient un message "Forbidden You don't have permission to access this resource."
https://www.forum-bassin.com/forum/imag ... 3b9_71.jpg
-> peut être une erreur de saisie aujourd'hui ? car au début de ce topic ils s'affichaient

- le lien d'affichage renvoyé par le file.php soit https://www.forum-bassin.com/forum/down ... 328695.jpg donne une erreur

Nota ; je ne sais pas faire lien entre le nom de l'image codée par file.php et le nom réel dans le dossier UPLOAD
peut être faut il chercher l'erreur dans cette transcodification ?

les manipulations faites sans succès
- les attributs des fichiers du dossier FORUM sont : IMAGES 755 , AVATARS 777, UPLOAD 705 !!! (si on change l'attribut par filezilla en 777 il repasse en 705, si on modifie les permissions il passe en 777 mais si on réinterroge il est revenu en 705 !!!) Pourtant il me semble que quand on a fait les tests demandéq par Sylveretour c'était bien 777
- les fichiers de UPLOAD .htaccess et index.htm et les fichiers de DOWNLOAD file.php et index.htm ont été renvoyés sur le serveur
- une migration de 3.3.0 vers 3.3.3 a été faite


les tests
- enlever dans le PCA la possibilité d'utiliser des avatars, puis purge, puis remise de la possibilité, puis purge KO
- vidage de tous les fichiers dans UPLOAD, puis purge, puis création d'un avatar KO


examen de tous les problèmes similaires dans le forum php
- ont été résolus par les manip d attributs de fichiers ou de renvoi sur le server du file.php
- sauf un qui pense a la fin que cela proviendrait d'un soucis avec la base de donnée puisque en faisant un test sur une nouvelle base de donnée aves ses avatars ca marche Mais le topic http://forums.phpbb-fr.com/support-util ... 14171.html ne se conclu pas par une explication résolution.
Ce pourrait être une piste ? par exemple si file.php utilisait un paramètre de la base de donnée pour coder les adresses des images ? La besoin d 'un programmeur connaissant le système :|

en l'attente du passage d une personne ayant ses connaissances

Avatar du membre
Sylveretour
Floodeur mature
Floodeur mature
Messages : 1753
Enregistré le : 21 nov. 2017 à 18:24
Localisation : West Coast
Contact :

Re: Avatar

Message par Sylveretour »

- les fichiers images dans le dossier UPLOAD sont bien présent.
Ils s'affichaient. Aujourd'hui ils renvoient un message "Forbidden You don't have permission to access this resource."
Peut-être la piste à suivre, supprime le fichier .htaccess du dossier images/avatars/upload/ pour mettre le neuf du pack phpBB
Nota ; je ne sais pas faire lien entre le nom de l'image codée par file.php et le nom réel dans le dossier UPLOAD
peut être faut il chercher l'erreur dans cette transcodification ?
Je t'ai déjà donné le pourquoi plus avant :
Les liens des avatars sont comme cela pour protéger d'éventuelles attaques avec des images contenant du code malicieux.
Ainsi, un utilisateur ne sera pas capable de connaitre le nom réel d'un avatar uploadé, il en va de même pour les fichiers joints.

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Re: Avatar

Message par ANNIES »

Toujours les mêmes qui participent :wink:

1 Oui pour .htacces Fait aussi J'avais oublié de le préciser :oops:
voici ce qu'il contient
# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_core.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
<IfVersion < 2.4>
Order Allow,Deny
Deny from All
</IfVersion>
<IfVersion >= 2.4>
Require all denied
</IfVersion>
</IfModule>
<IfModule !mod_version.c>
<IfModule !mod_authz_core.c>
Order Allow,Deny
Deny from All
</IfModule>
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
</IfModule>
J'ai remis un fichier Htaccess de 2015
qui contient
<Files *>
Order Allow,Deny
Deny from All
</Files>
Ca marche, les images en suivant le lien
https://www.forum-bassin.com/forum/imag ... b9_101.jpg
s'affichent
Bizarre avec le fichier 3.3.3 de base ca ne marche pas et avec un vieux fichiers ca marche Va comprendre Charles ..

2 Pour le nom du fichier renvoyé par file.php j'avais bien suivi ton explication qu'il était différent
Ce que je ne sais pas c'est comment il fabrique ce nom
Si c'était un codage du nom réel Il pourrait être fait avec une clef, clef, qui pourrait être dans la base de donnée et qui pourrait être perturbée ... ou alors il va bien chercher le fichier avec la bonne adresse et annonce une url différente ?

Parce que si cela ne vient pas des paramètres PCA, des fichiers, des dossiers, des programmes, de l'hébergeur .. reste la base de donnée. Et comme les fichiers n'y sont pas ,,, que peut il y avoir qui perturberait le fonctionnement

3 c'est une histoire de fou
- les attributs des fichiers du dossier FORUM sont maintenant: IMAGES 777 , AVATARS 777, UPLOAD 777 !!!
Ce qui a changé ? J'ai mangé ... :roll: Donc j'ai relancé Filezilla Et la ca reviens comme il se doit

mais toujours pas les avatars :twisted: et si je retournais manger ? :lol:

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Re: Avatar

Message par ANNIES »

EDIT : Fait nouveau
au lieu d'importer un fichier de mon PC Ce qui ne marche plus :twisted:
J ai copier toutes les images du dossier UPLOAD dans le dossier GALLERY et la... quand je charge l'avatar pour un membre a partir de gallery je vois toutes les images et peut choisir et charger une image pour ce membre
en ce cas le lien de l avatar dans le profil est
https://www.forum-bassin.com/forum/imag ... 3b9_62.jpg
C est à dire le nom de l image telle qu elle a été nommée lors de son transfert vers upload

Donc
l'image est bonne Pas de perturbations
la fonction MODIFIER /CRÉER L AVATAR du PROFIL fonctionne avec la gallery
la fonction affichage de phpBB de l avatar issue de la gallery fonctionne dans le profil et dans le forum
les images de UPLOAD sur le navigateur s'affichent après modification du fichier htaccess
On peut écarter une responsabilité du serveur Apache puisque la même image s affiche ou pas dans le profil du membre suivant qu elle vient de Gallery en lien direct OK ou de upload par file.php KO

-> le problème est sérié sur file.php
rappelons qu il a été changé et par la mise a jour 3.3.3 et ensuite par le zip de PHP 3.3.3 Cela sans effet

Utiliser la gallery serait une solution temporaire pour les membres (a conditions qu'ils aillent tous modifier leur avatar et le refassent quand on trouvera le coupable )
Mais solution pas durable car les nouveaux ne peuvent transférer leur logo dans GALLERY

Et puis ce serait bien de trouve le loup


Ce que je ne sais pas ,
si quelqu un à cette information ?
si file.php utilise la base de donnée ?
Si le membre utilise un avatar de la gallery , il s affiche avec sa vrai url dans le dossier gallery
Si le membre utilise un avatar transféré il est chargé par file.php dans le dossier upload et à ce moment il s affiche avec une url bidon chargé de cacher la vrai url du fichier
Donc
Où file.php se contente d afficher cette url Donc pas de piste ou ce situe l erreur
Où file.php lit dans la base de donnée le profil du membre et peut être le lien du fichier dans upload Alors le problème serait la Cette info pourrait être perturbée Donc comment réinitialiser cette info ?

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Avatar

Message par ANNIES »

Bonjour
On cherche
sur le file.php on me dit qu'il y a une ligne blanche en haut de la sortie
je ne sais pas supprimer cette ligne blanche

ceci après mise a jour en 3.3.3
si je télécharge le pack Php 3.3.3 de base
hors j'ai renvoyé le file.php du pack de base

pouvez vous m'indiquer comment supprimer cette ligne ou m'envoyer un file.php 3.3;3 correct ?
le fichier file.php a été mise a jour par la 3.3.3 le 27/3 et a été renvoyé du pack avant mise a jour (ca marchait deja pas depuis deux jours)
et aurait le même problème avec le fichier config.php Hors ce fichiers config.php date du 25/03/2021 sur le server alors que tous les autres files date du 27/3/2021 date de la mise a jour
il y aurait t il eu un piratage le 25/3 (date a la quelle cela a arrêté de fonctionner)


le seul file.php que j'ai avant ce problème date de 2015, idem config.php Je n'ose pas trop les envoyer sur le site



voici le file , ou est la ligne blanche ???
code supprimé par un modérateur

Avatar du membre
cocooncrash
Resp. des modérateurs
Resp. des modérateurs
Messages : 8200
Enregistré le : 07 janv. 2008 à 08:29
Localisation : dans un bocal en compagnie de nemo!!
Contact :

Avatar

Message par cocooncrash »

Bonjour,
Attention au fichier que vous insérez ici, vu le nombre de ligne.

Revoyez les règles, notamment la 1.2.5 :
Si votre message d’erreur fait référence à une ligne (ou à un fichier) de phpBB, et que celui-ci est inférieur à 20 lignes, insérez-le dans votre message à l’aide du BBCode

Code : Tout sélectionner

. Si cela excède la limite précédemment citée, enregistrez-le dans un fichier texte, envoyez ce fichier texte sur votre FTP (à défaut un nopaste tel que Pastebin) puis donnez-nous le lien pour que nous puissions l’examiner.[/quote]

Jevais éditer votre message pour supprimer ces lignes, a vous de l'envoyer come indiqué ci dessus. Cordialement.
decouvrez l'aide complete : ICI
découvrez les règles : La_bas

Pensez a ajouter le tag [réglé] en modifiant votre premier message s'il est résolu. Merci :wink:

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Avatar

Message par ANNIES »

j'ai mis le file.php dans un file.txt
que j'ai mis ici

https://www.forum-bassin.com/docum/file.txt

merci de votre assistance

Avatar du membre
On Stage
Roi des posts
Roi des posts
Messages : 924
Enregistré le : 19 mars 2018 à 16:04
Contact :

Avatar

Message par On Stage »

Salut Annies
En lisant ton avant dernier message je comprends que tu as fait la mise à jour vers phpBB 3.3.3 mais en gardant des anciens fichiers de versions antérieure :
le fichier file.php a été mise a jour par la 3.3.3 le 27/3 et a été renvoyé du pack avant mise a jour (ca marchait deja pas depuis deux jours)
Si je comprends bien la tournure de cette phrase ce n'est pas ainsi que l'on met à jour son forum.
phpBB version: 3.3.4
php version: 8.0.3

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Avatar

Message par ANNIES »

Désolée de m être mal exprimé dans ce résumé des actions
Le problème est apparu le 25/3
Le 26/3 sur conseil ici nous avons renvoyé file.php sur le serveur Sans résultat
Ensuite nous avons fait la mise a jour 3.3.3
Par la suite nous avons téléchargé une version clean d installation de php 3.3.3 et avons renvoyé son fichier file.php sur le serveur

A part ca voyez vous une ligne blanche sur ce fichier ?

Avatar du membre
On Stage
Roi des posts
Roi des posts
Messages : 924
Enregistré le : 19 mars 2018 à 16:04
Contact :

Avatar

Message par On Stage »

Non je ne vois pas de ligne blanche dans ce fichier, le mieux serait de renvoyer les fichiers de base de la version 3.3.3 conformément à la procédure du tuto de mise à jour.
phpBB version: 3.3.4
php version: 8.0.3

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Avatar

Message par ANNIES »

Bonjour
Bon on ne trouve pas le problème
En général quand un problème survient On se demande ce qui s est passé juste avant Ce qui était exprimé au début par les contributeurs Rien ! On n avait rien modifié
On a suivi les conseils de renvoi sur le serveur de fichiers suspects index file htaccess
On a fait une mise a jour 3,3,0 -> 3,3,3
On a contrôlé les attributs des fichiers 777
On a purgé X fois On a enlevé le paramètre des affichages des avatars dans le PCA puis remis
On a questionné OVH
Tout cela selon vos conseils :D

On a déterminé que les fichiers avatar étaient bien présents dans UPLOAD
Que la création d'un nouveau fichier, le créé. Que la suppression, le supprimé. Mais qu'il ne s affichait pas :evil:

On a suivi des fausses pistes :cry:
On a même pensé a un piratage Et a défaut de trouver le ver on a pisté tous ceux s étant inscrit le 25/3 et ce qu'ils avaient fait

On a transféré les fichiers dans Gallery et la ils s affichent :idea:
Donc ça ne vient pas de file.php, ni des fichiers,
Deux seules pistes plausibles demeurent
- que l adresse du fichier affiché dans l'url derrière /file.php?avatar= soit lue dans la base de donnée en fonction de l'user d'après un paramètre xxx et qu'elle soit renvoyée fausse Seulement la on ne sait pas ou sont mémorisé ces codes
De surcroît le code user=adresse de l'avatar dans la Gallery fonctionne
- comme c'etait conseillé ici pour un autre topic, on s est inscrit sur php.com et on a posé la question
https://www.phpbb.com/community/viewtop ... &t=2590216.
Ils suspectent qu'une blakline soit générée par config.php ou les fichiers linguistiques Mais la on ne voit pas comment cela serait apparu soudainement Et on a pas trouvé de blakline

Donc comme nos membres tiennent à leurs avatars, et en attendant que quelqu'un passe ici, et hop ait la solution...
On va utiliser la gallery
Mais comme on ne sais quelle image est l'avatar de tel membre...
On va demander aux membres de choisir dans Galery, quel est leur avatar

Seulement un problème: 3000 membres , des centaines d'avatars, et des tas de membres qui ne passent pas souvent...
Donc des avatars gallery qui s'affichent et des avatars upload qui ne s'affichent pas et qui donnent un aspect de cimetière a l'abandon au forum pour tous nouveaux visiteurs

Question :
Existe il un moyen d'effacer en une seule fois le lien vers l'avatar dans tous les profils ?
Ainsi plus personne n'affichera un carré vide sous son profil avec la mention "avatar du membre " comme ici
https://www.forum-bassin.com/forum/view ... f=11&t=473

Et comme je ne suis pas une connaisseuse de myphpadmin il me faudrait une instruction très claire a exécuter

Penser a une nulle ..et écrivait cela pour qu'elle comprenne et ne casse pas tout :|

Skouat
Resp. Traducteurs
Resp. Traducteurs
Messages : 15182
Enregistré le : 02 avr. 2008 à 20:47
Contact :

Avatar

Message par Skouat »

Hello,

As-tu changé de logiciel d'édition de fichiers texte ?

Auteur
ANNIES
Apprenti-posteur
Apprenti-posteur
Messages : 179
Enregistré le : 09 déc. 2007 à 15:27
Contact :

Avatar

Message par ANNIES »

Oui c'est fait
Mais personne ne voit cette ligne blanche a supprimer dans file.php, qu'avait indiqué un contributeur
On a laissé cette piste Le contributeur s'étant lui même retracté

Répondre

Retourner vers « Utilisation »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 8 invités