Transfert forum 3.0.11 et mise à jour 3.3.5

Forum concernant les demandes de support pour tout problème de mise à jour d'un forum phpBB 3.3.x depuis une version antérieure ou d'une conversion de phpBB2 ou phpBB3 vers phpBB 3.3

Modérateur : Équipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com

Pensez à effectuer une recherche, la réponse à votre question a de grandes chances d'avoir déjà été donnée.
Répondre
Auteur
Chris74
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 08 nov. 2021 à 17:22

Transfert forum 3.0.11 et mise à jour 3.3.5

Message par Chris74 »

Bonjour,

J'ai lu pas mal de topic mais je ne pense pas avoir trouvé le bon.

Notre association doit changer d'hébergeur.
Pour le site internet sous WP, tout s'est très bien passé.
On doit maintenant transférer le forum en version 3.0.11, hébergé en .com vers .fr hébergé chez O2Switch.

L'hébergement en.com n'est plus à jour et intouchable, donc exit l'idée la mise à jour sur cet hébergement.
Je peux sauvegarder uniquement la base de donnée via le panneau de configuration du forum et j'ai un accès FTP.

Quelle est la meilleure démarche à suivre pour récupérer le forum ?

J'ai dans un premier temps suivi les consignes :
- sauvegardes base de données et transfert ftp des fichiers
- réinstallation des fichiers sur le nouvel hébergeur
- création de la nouvelle base de données et réimportation (mode binaire) avec modification de config.php
- mise en place du pack complet 3.3.5, en prenant soin des conserver/supprimer les dossiers et config.php qui sont précisés
- modifications dans la base de données des .com en .fr, du port http en https, des adresses http en https

J'ai en suite lancé l'INSTALL du pack.
La procédure d'installation s'est déroulée jusqu'à 100%, mais avec un message d'erreur.
General Error:SQL ERROR [ mysqli ] [0]SQLNo values specified for SQL IN comparison in file /home/ycwn1583/public_html/forum/phpbb/db/driver/driver.php on line 1023
avec cette seconde ligne :
Installing Data: \phpbb\db\migration\data\v32x\fix_user_styles.

Lorsque je vérifie mon accès au forum en renommant install-old, j'arrive à me connecter avec un identifiant, j'ai l'accès au panneau de configuration, mais je n'ai pas accès à l'intérieur des échanges du forum. Je vois bien tous les menus et sous menus. Mais j'ai ensuite ce message d'erreur :
Fatal error: Uncaught Symfony\Component\DependencyInjection\Exception\ServiceNotFoundException: You have requested a non-existent service "profilefields.type.googleplus". Did you mean one of these: "profilefields.type.bool", "profilefields.type.date", "profilefields.type.dropdown", "profilefields.type.text", "profilefields.type.url", "profilefields.type_collection"? in /home/ycwn1583/public_html/forum/vendor/symfony/dependency-injection/Container.php:348 Stack trace: #0 /home/ycwn1583/public_html/forum/phpbb/di/service_collection.php(57): Symfony\Component\DependencyInjection\Container->get('profilefields.t...') #1 /home/ycwn1583/public_html/forum/phpbb/profilefields/manager.php(455): phpbb\di\service_collection->offsetGet('profilefields.t...') #2 /home/ycwn1583/public_html/forum/viewtopic.php(1918): phpbb\profilefields\manager->generate_profile_fields_template_data(Array) #3 {main} thrown in /home/ycwn1583/public_html/forum/vendor/symfony/dependency-injection/Container.php on line 348

Pourriez-vous m'aiguiller svp ?

Bien cordialement.
Christophe
Avatar du membre
Bid0uille
Roi des posts
Roi des posts
Messages : 604
Enregistré le : 18 nov. 2005 à 16:42
Localisation : Saumur, France
Contact :

Transfert forum 3.0.11 et mise à jour 3.3.5

Message par Bid0uille »

Passer d'une 3.0 à une 3.3 m'apparaît hasardeux. La structure de la base et des tables ayant évolué.
Détaillez comment vous avez réimporté les données.
Enfin un Forum francophone pour OpenOffice et ses dérivés !
L'ensemble des forums officiels pour OpenOffice (10 langues) est propulsé par PhpBB
Auteur
Chris74
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 08 nov. 2021 à 17:22

Transfert forum 3.0.11 et mise à jour 3.3.5

Message par Chris74 »

J'ai réimporté les données simplement dans phpmyadmin.
Avatar du membre
On Stage
Empereur des posts
Empereur des posts
Messages : 1053
Enregistré le : 19 mars 2018 à 16:04
Localisation : Pays de la Loire
Contact :

Transfert forum 3.0.11 et mise à jour 3.3.5

Message par On Stage »

Salut
Tu peux suivre ce tuto (en anglais) : https://www.phpbb.com/support/docs/en/3 ... /upgrade3/
phpBB version: 3.3.5 | php version: 7.4.25
Quelques traductions d'extensions - GitHub - Arrêter le spam sur phpBB
Auteur
Chris74
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 08 nov. 2021 à 17:22

Transfert forum 3.0.11 et mise à jour 3.3.5

Message par Chris74 »

Salut l’Empereur des Postes.
Ok.Merci. Je reviens vers vous dès que j'ai avancé.
Auteur
Chris74
Posteur néophyte
Posteur néophyte
Messages : 4
Enregistré le : 08 nov. 2021 à 17:22

Transfert forum 3.0.11 et mise à jour 3.3.5

Message par Chris74 »

Bonjour et merci.

Pour revenir sur mon transfert, j'ai considérablement avancé en suivant les explications de Skouat ici :
viewtopic.php?f=277&t=214149

Très important : remettre le forum sur Prosilver et en anglais avant de transférer.

Aujourd'hui, le forum est réinstallé, hors il me reste un point qui n'a pas fonctionné.
Les pièces jointes ne sont pas visibles.
Exemple ici :
https://clubvedettefrance.fr/forum/viewtopic.php?t=3957

L'ancien forum, on voit qu'elles apparaissent bien :
http://clubvedettefrance.com/forum-old/ ... =13&t=3957

Qu'ais-je pu raté ou oublié ?

Cordialement.

Ajouté 5 heures 38 minutes 54 secondes après :
Ok. J'ai retransféré les fichiers du dossier Files une seconde fois, en binaire et là, tout fonctionne.
Avis perso : ne pas hésiter à transférer 2 ou 3 fois les fichiers.

Merci à tous.

Christophe
Répondre

Retourner vers « Mises à jour/Conversions »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités