[Réglé][Thanks for post 2.07] Je n'arrive plus a faire fonctioner l'extensions

Support pour n'importe quelle extension non présente dans notre base de données
Aucune demande de personnalisation des extensions n'est autorisée.

Modérateur : Équipe

Règles du forum
A lire impérativement : Règlement de phpBB-fr.com - Conditions générales de support des extensions de phpBB-fr.com

Merci de mettre le nom de l'extension ainsi que sa version entre crochets, et un titre explicite afin de faciliter la recherche.
Exemple : [nom de l'extension + numéro de version] Titre explicite résumant le problème

Le lien de téléchargement de l'extension est demandé pour toute demande de support.

Aucune demande de personnalisation des extensions n'est autorisée.
Répondre
Auteur
janko13
Posteur néophyte
Posteur néophyte
Messages : 39
Enregistré le : 20 mars 2013 à 00:38

[Réglé][Thanks for post 2.07] Je n'arrive plus a faire fonctioner l'extensions

Message par janko13 »

Bonjour a tous
Depuis un certain temps cette extension ne fonctionne plus.
Je peux ni l'activer ni la supprimer
Lien : https://www.phpbb.com/customise/db/download/180581
Version Phpbb : 3.3.4

quand je l'active j'ai un retour d'erreur:
Erreur générale
SQL ERROR [ mysqli ]
Key column 'user_id' doesn't exist in table [1072]
SQL
ALTER TABLE phpbb3_thanks ADD INDEX user_id (user_id)
BACKTRACE
FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 1023
CALL: trigger_error()
FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 195
CALL: phpbb\db\driver\driver->sql_error()
FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 1011
CALL: phpbb\db\driver\mysqli->sql_query()
FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 1477
CALL: phpbb\db\tools\tools->_sql_run_sql()
FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 621
CALL: phpbb\db\tools\tools->sql_create_index()
FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools\tools->perform_schema_changes()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 714
CALL: call_user_func_array()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 661
CALL: phpbb\db\migrator->run_step()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 400
CALL: phpbb\db\migrator->process_data_step()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 351
CALL: phpbb\db\migrator->try_apply()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 351
CALL: phpbb\db\migrator->try_apply()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 288
CALL: phpbb\db\migrator->try_apply()
FILE: [ROOT]/phpbb/db/migrator.php
LINE: 241
CALL: phpbb\db\migrator->update_do()
FILE: [ROOT]/phpbb/extension/base.php
LINE: 78
CALL: phpbb\db\migrator->update()
FILE: [ROOT]/ext/gfksx/thanksforposts/ext.php
LINE: 54
CALL: phpbb\extension\base->enable_step()
FILE: [ROOT]/phpbb/extension/manager.php
LINE: 231
CALL: gfksx\thanksforposts\ext->enable_step()
FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 209
CALL: phpbb\extension\manager->enable_step()
FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()
FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()

et quand je la supprime j'ai ce message :
Un problème a été rencontré durant l’opération de mise à jour de la base de données. Les modifications déjà appliquées ont été annulées du mieux possible, veuillez vérifier que votre forum ne comporte pas d’erreur.

Un module porte déjà ce nom : ACP_THANKS

quelqu'un a t’il déjà eu ce problème et quel peut être la solution

Merci
Modifié en dernier par janko13 le 01 juin 2021 à 20:08, modifié 8 fois.
Avatar du membre
Steph
Administrateur
Administrateur
Messages : 21062
Enregistré le : 29 déc. 2008 à 15:48
Localisation : Alsace / Bas-Rhin / France
Contact :

[Thanks for post 2.07] Merci de modifier le titre du sujet afin qu'il soit plus explicite.

Message par Steph »

Salut,

Tout d'abord, un simple "ne fonctionne pas" n'est pas un titre de sujet explicite, c'est même trop générique. Merci de choisir un titre en adéquation avec la demande.

Ensuite, comme indiqué dans la cadre rouge ci dessus, merci d'indiquer le lien de téléchargement de l'extension.

Précise également la version de phpBB utilisé.
Avatar du membre
On Stage
Roi des posts
Roi des posts
Messages : 962
Enregistré le : 19 mars 2018 à 16:04
Contact :

[Thanks for post 2.07] Je n'arrive plus a faire fonctioner l'extensions

Message par On Stage »

Salut
Alors je te confirme que la version 2.0.7 de cette extension fonctionne parfaitement avec phpBB 3.3.4, une mise à jour a été faite, et est disponible sur Github, pour la rendre compatible avec la version 8.0 de php.

Rapport à ton problème il y a une discussion ici avec cette solution : viewtopic.php?p=1652156#p1652156

Pense à faire un backup de ta base de données avant toutes modifications.
phpBB version: 3.3.4
php version: 8.0.7

Mes traductions d'extensions
Auteur
janko13
Posteur néophyte
Posteur néophyte
Messages : 39
Enregistré le : 20 mars 2013 à 00:38

[Thanks for post 2.07] Je n'arrive plus a faire fonctioner l'extensions

Message par janko13 »

Merci pour l'info, j'ai réussi a la désinstaller .
Répondre

Retourner vers « Support des extensions non présentes dans notre base de données »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité