[Réglé] Probleme avec "citer"

Le forum de support pour les questions concernant l'utilisation de phpBB2, les problèmes rencontrés au cours de telle ou telle manipulation du forum, ou les changements que vous souhaiteriez effectuer.

Modérateur : Equipe

Règles du forum
A lire impérativement sur notre page : Règlement

Pensez à effectuer une recherche et à prendre connaissance du forum de documentation, la réponse à votre question a de grandes chances de s'y trouver.

- Plus aucun support n'est délivré pour phpBB2 depuis le 1er janvier 2009
Verrouillé
Auteur
CHEIKH
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 26 oct. 2005 à 00:43

[Réglé]Probleme avec "citer"

Message par CHEIKH »

Salut tout le monde ; J'ai un probleme avec le bouton "citer" , quand un membre utilise ce bouton ; voila ce qu'il donne

Code : Tout sélectionner

[quote="user"]Message.[/quote] 


Par contre s'il est utilisé par l'administrateur la citation passe normal ; SVP j'ai besoin d'aide .

N.B : Je suis pas trés doué en PHP .
Modifié en dernier par CHEIKH le 14 avr. 2006 à 04:39, modifié 1 fois.

spitfire pat
MOD Contest Winner
Messages : 15297
Enregistré le : 18 sept. 2004 à 16:43
Localisation : bourgogne

Message par spitfire pat »


Auteur
CHEIKH
Posteur néophyte
Posteur néophyte
Messages : 7
Enregistré le : 26 oct. 2005 à 00:43

Message par CHEIKH »

C'est trés gentil . Merci infiniment

pour ce qui ont le même probleme :

ouvrir /includes/functions_post.php et chercher

Code : Tout sélectionner

$message = addslashes($message); 



remplacer par :

Code : Tout sélectionner

$message = str_replace('"', '\"', $message); 

Avatar du membre
and1hotsauce
Grand-maître des floodeurs
Grand-maître des floodeurs
Messages : 3517
Enregistré le : 19 oct. 2003 à 14:58
Localisation : belgique, mons
Contact :

Message par and1hotsauce »

Votre requête étant résolue, merci d'ajouter l'attribut de sujet [Réglé] ;-)

A+, And1Hotsauce ;-)

simtran
Posteur néophyte
Posteur néophyte
Messages : 1
Enregistré le : 07 juin 2006 à 16:13

Message par simtran »

CHEIKH a écrit :C'est trés gentil . Merci infiniment

pour ce qui ont le même probleme :

ouvrir /includes/functions_post.php et chercher

Code : Tout sélectionner

$message = addslashes($message); 



remplacer par :

Code : Tout sélectionner

$message = str_replace('"', '\"', $message); 


Si mis en plus et non en remplacement, les apostrophes sont aussi gérés sur les sites ou ils ne passaient pas au niveau SQL.

Verrouillé

Retourner vers « Utilisation »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité