proflat

Erreur : 0 à la sélection du style - proflat

Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 03 Oct 2017 à 15:39

Bonjour,

Je rencontre une erreur : 0, avec le message d'erreur ci-dessous, dès que l'on sélectionne ce style via le panneau de l'utilisateur. :?

Code: Tout sélectionner
Unknown "path" function in "overall_header.html" at line 12.


Quel est la solution à ce souci ?

Merci d'avance. :)
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Mazeltof » 05 Oct 2017 à 17:43

'jour ici,

Jamais eu ce type de bug avec proflat :roll:

version du(es) style(s) utilisé(s) et url du forum, stp ?
un compte test serait également idéal pour voir en en direct :wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2154
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 05 Oct 2017 à 17:58

Merci Mazeltof,

Je t'envoie les paramètres de connexion du compte test en MP. 8)
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Mazeltof » 06 Oct 2017 à 09:13

'jour ici,

Tu peux déjà installer la bonne version de proflat, c'est la 1.1.11 pour phpBB 3.1.11 :P

sélectionne l'onglet révision (en bas) dans le détail de la contribution pour avoir toutes les versions.
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2154
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 06 Oct 2017 à 14:36

Bonjour,

Oui, effectivement, c'est mieux avec la bonne version, merci. :mrgreen:

Mais bon, j'ai beaucoup de décalages et des boutons (répondre) qui ne s'affichent pas entièrement. Problèmes sûrement liés à l'intégration dans Joomla... :?

Dommage... :cry:
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Mazeltof » 06 Oct 2017 à 15:36

Si prosilver s'affiche normalement, (sauf modifications divers et variées) proflat doit faire de même.
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2154
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 06 Oct 2017 à 15:49

En fait, j'utilise jprosilver (à base de prosilver donc) qui est un style modifié, fourni par l'éditeur du bridge Joomla/phpbb. 8)

Que faudrait-il modifier dans le style proflat pour avoir un affichage parfait ? Est-ce compliqué à faire ?
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Mazeltof » 06 Oct 2017 à 17:08

Sans connaitre les modifications apportées à prosilver pour ton forum c'est difficile à dire.

Tu peux déjà modifier proflat en style hérité de jprosilver et voir ce que ça donne.
Ensuite, voir les modifications apportées à jprosilver et adapter proflat en conséquence.
Si jprosilver est hérité de prosilver ça ne devrait pas être trop compliqué, par contre s'il n'est pas hérité il faut comparer tous les fichiers pour retrouver les modifications et là y a du taff :mrgreen:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2154
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 09 Oct 2017 à 20:06

Bonsoir,

Après questionnement à l'éditeur du bridge sur les modifications à faire, j'ai eu la réponse suivante :

Hide
Please explore our jprosilver style: it's inherited from native prosilver and main changes are in overall_header.html and overall_footer.html templates.

Wrapped forum is displayed inside Joomla template, hence phpBB style should not produce full-featured HTML document with <html>, <head> and <body> tags.


Une piste sur ce que je devrais modifier ?

Merci d'avance. :wink:
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Mazeltof » 09 Oct 2017 à 21:47

'soir ici,

je crois que c'est clair,
il faut comparer les fichiers overall_header.html et overall_footer.html, les modifications sont principalement dans ces fichiers.
Ensuite, reste à voir pour adapter proflat.

Je n'ai pas top le temps en ce moment mais prépare moi un zip de ton style Jprosilver. j'essaierai d'y jeter un oeil (mais ça ne sera pas pour tout de suite, va falloir être patient)
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2154
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 10 Oct 2017 à 21:39

Hide
Mazeltof a écrit:
Je n'ai pas top le temps en ce moment mais prépare moi un zip de ton style Jprosilver. j'essaierai d'y jeter un oeil (mais ça ne sera pas pour tout de suite, va falloir être patient)


Bonsoir,

Merci d'avance, je t'envoie un lien par MP. :D
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Mazeltof » 20 Oct 2017 à 10:30

'jour ici,

Je t'ai préparé un zip du style proflat hérité au style (jprosilver) que tu utilises sur ton site.
jproflat.zip
(331.22 Kio) Téléchargé 61 fois

N'ayant pas d'environnement Joomla pour mon forum de dev, je te conseil vivement de tester en local pour faire tes essais avant d'installer en prod et de faire une sauvegarde complète de ton site/forum avant d'installer.

S'il y a encore quelques modifications ponctuelles à apporter pour finaliser, n'hésite pas :wink:
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2154
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 12 Nov 2017 à 09:58

Bonjour Mazeltof,

Hélas, même avec la version que tu m'as préparé, les problèmes sont toujours présents... :cry:

C'est dommage, je le trouve très bien fait et sympa le proflat. :)
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Mazeltof » 13 Nov 2017 à 19:07

'soir ici,

J'ai jeté un oeil rapidement, tu as une interaction avec les feuilles de style de /yoo_catalyst
tu as également une feuille de style spécifique : p8bb.css dans laquelle on voit une classe .phpbb sur pas mal de règles css.
Cette classe n'existe pas par défaut dans prosilver, il faut l'ajouter dans le html du style et voir (sans éplucher d'avantage, je ne sais pas si ça corrigera).

ouvre jproflat/template/overall_header.html.
trouve (vers la ligne 60) :
Code: Tout sélectionner
<body id="phpbb" class="nojs notouch section-{SCRIPT_NAME} {S_CONTENT_DIRECTION} {BODY_CLASS}">

remplace par :
Code: Tout sélectionner
<body id="phpbb" class="phpbb nojs notouch section-{SCRIPT_NAME} {S_CONTENT_DIRECTION} {BODY_CLASS}">

et regarde ce que ça donne.

Je pense que quelque soit le style que tu voudras utiliser (sauf jprosilver, puisque adapter pour toi) te posera les mêmes soucis.
Cela dit il faudrait que tu compares les pages html présentes dans jproflat, avec celles de jprosilver si elles y sont, pour voir si différences il y a et les adapter au besoin.
Image Image Image
Avatar de l’utilisateur
Mazeltof
Resp. des graphistes
Resp. des graphistes
 
Messages: 2154
Enregistré le: 09 Mar 2009 à 22:02
Localisation: Arras

Re: Erreur : 0 à la sélection du style

Nouveau messagepar Patrik69 » 03 Déc 2017 à 11:18

Bonjour,

Bon ben, je laisse tomber, tout ça est au-dessus de mes compétences. :|

EDIT : J'ai tenté une petite astuce, j'ai intégré le forum, dans Joomla, via une Fenêtre Intégrée (IFrame), le résultat n'est pas trop mal, je pense que je vais garder cette option. :)
Petite question technique : J'ai modifié les url des icônes des réseaux sociaux du bas du forum, jusque là pas de soucis. Comment faire pour que ces liens s'ouvrent dans un nouvel onglet, mais dans la même fenêtre, du navigateur (CHROME) ? Merci d'avance. 8)
Patrik69
Apprenti-posteur
Apprenti-posteur
 
Messages: 109
Enregistré le: 18 Oct 2005 à 16:13
Localisation: Pays Basque


Connexion  •  M’enregistrer

cron