Aqua-Marine

[Réglé] Version 3.1.8 - Aqua-Marine

[Réglé] Version 3.1.8

Nouveau messagepar yanneton » 09 Mar 2016 à 19:00

Bonjour Sub :)

Juste une petite question :
Je n'ai pas trouvé la différence sur ta démo.Quelles sont les modifs apportées à cette nouvelle version ?

Question de savoir si mon forum est concerné....

Merciiiii..... ;)
Avatar de l’utilisateur
yanneton
Posteur néophyte
Posteur néophyte
 
Messages: 45
Enregistré le: 08 Déc 2007 à 15:30
Localisation: Saint Dié VOSGES

Re: Version 3.1.8

Nouveau messagepar Steph » 09 Mar 2016 à 22:51

Salut,

Si tu ne vois pas de différence c'est peut être tout simplement que le style a juste été mis à jour pour être conforme à la dernière version de phpBB qui est sortie il n'y a pas si longtemps.

Donc si ton forum est dans une version antérieure à 3.1.8 et que tu as fait cette mise à jour, tu es concerné.
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17600
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Version 3.1.8

Nouveau messagepar yanneton » 10 Mar 2016 à 04:24

Salut,

Évidemment.
Si je pose la question c'est aussi évident que je suis en Aqua_Marine 3.1.7.

Mais ça ne répond pas à ma question.
Sur l'Aqua-Marine de sub j'ai tout changé. Couleurs, graphismes et d'autres choses. Il me faudrait tout refaire je suppose.

Je pose ma question différemment : Lorsque je ferai la mise à jour phpbb de 3.1.7pl1 en3.1.8 sera-t-il nécessaire de faire absolument la maj du style ? C'est pour cela que je demande les détails. Également pour savoir si je peux faire les changements "à la main" sur mon style sans devoir tout refaire. Et quels sont ces changements. Ça ne doit pas être si terrible.
Je vais finir par regretter les mods, moi... Au moins on avait les codes. Beaucoup moins simple, certes, mais pratique et souple.

Merci quand-même pour le commentaire.

P.S. Pour éviter une autre réponse laconique du genre :

Sub, serait-ce compliqué pour toi de me donner les changements à faire à la main sur ma version 3.1.7 afin de ne pas devoir refaire tout mon style perso sur lequel tu m'as si bien aidé ?

Merci d'avance. ;)
Avatar de l’utilisateur
yanneton
Posteur néophyte
Posteur néophyte
 
Messages: 45
Enregistré le: 08 Déc 2007 à 15:30
Localisation: Saint Dié VOSGES

Re: Version 3.1.8

Nouveau messagepar Steph » 10 Mar 2016 à 07:36

Non ce n'est pas si évident de savoir que tu es en version 3.1.7 à moins que tu nous prenne pour des voyants, tu es seul à savoir ce que tu fais sur ton forum.

Quoi qu'il en soit, oui tu dois mettre le style à jour dans la même version que le forum, la c'est une évidence, pas besoin de deviner.

Les extensions sont beaucoup mieux que les MOD puisque tu n'as pas besoin de toucher aux fichiers pour ajouter des fonctionnalités.

Pour mettre à jour le style vers la dernière version, tu trouveras les modifications à faire dans notre documentation dont le lien se trouve ci-dessus, mais encore faut il prendre la peine de faire une recherche (3 clics tout au plus).

Bon je vais t'éviter deux clics de souris : http://forums.phpbb-fr.com/documentatio ... -view.html
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17600
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Version 3.1.8

Nouveau messagepar sub60 » 10 Mar 2016 à 14:02

Salut,

Alors oui, tout styles phpbb ce trouve concerner par les mise à jour dès lors qu'une mise à jour phpbb sort,
Donc pour les styles autre que prosilver(dit exotique), il faut faire les mise à jour manuellement,
dans le centre de documentation un forum mise à jour et justement dédié a cela http://forums.phpbb-fr.com/documentation/
et vu que mes styles utilise l'héritage de prosilver, il y a donc peut de fichier a mettre à jour manuellement.

Et pour répondre à ta question, le changement n'est pas forcément visuel, mais des portions de code change/évolue,
ainsi que depuis les extensions le style en prend plein la tronche avec l'ajout d'évent pour que les extensions s'y retrouve dans le code :wink:
<< Comment poster au bon endroit sur phpbb-fr >>
Attention..!! les styles pour phpBB 3.0, ne sont pas compatible avec phpBB 3.1
Sur phpBB 3.1, pour rafraîchir le style il suffit de vider le cache du forum.
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Avatar de l’utilisateur
sub60
Floodeur universel
Floodeur universel
 
Messages: 9518
Enregistré le: 19 Juin 2006 à 14:14
Localisation: oise

Re: Version 3.1.8

Nouveau messagepar yanneton » 11 Mar 2016 à 19:51

Bonsoir :)

Merci Steph et Sub.

Ça c'est de la réponse claire et nette, comme je l'aime. ;)

Le lien de Steph est exactement ce que je voulais, et m'a effectivement fait économiser un click par rapport à celui de Sub. :D

Il n'était pas évident pour moi de savoir que le style de sub réponde à une généralité. Sinon, j'aurais fait une recherche, bien-sûr. Mais j'aurais tout de même posé la question pour être sûr de ne pas me tromper.
Le phpbb est fabuleux de par ses possibilités, mais reste une usine à gaz où parfois la plus simple des logiques n'apparaît pas forcément à un "bricoleur". C'est bien pour ça que ce forum est si précieux.

Encore merci à vous deux et bon courage aux "stylistes". ;)

Edit et P.S.

Pour Sub, juste une suggestion : Je sais que ça représenterait un gros travail en plus, mais ce qui serait génial pour des bricolous dans mon genre (et il y en a beaucoup) ce serait 2-3 mots de définition devant les groupes de codes.
Ex : Code machin /* position latérale bouton recherche */ . Enfin, tu vois le genre. Ce qui éviterait énormément de questions récurrentes.
Une approche de ce genre est déjà en place (du moins sur tes styles, mais je le vois de plus en plus) ce qui aide beaucoup.
Avatar de l’utilisateur
yanneton
Posteur néophyte
Posteur néophyte
 
Messages: 45
Enregistré le: 08 Déc 2007 à 15:30
Localisation: Saint Dié VOSGES


Connexion  •  M’enregistrer

cron