Support Toolkit

Erreur générale lors du lancement de STK - Support Toolkit

Erreur générale lors du lancement de STK

Nouveau messagepar Leon73 » 02 Jan 2017 à 12:07

Bonjour,
Mon forum est en version 3.0.12 et je suis en train de suivre la procédure pour le passer en version 3.1.10.
J'ai donc chargé l'outil STK et sa version française dans le répertoire "forum" mais lorsque je vais sur http://www.royalenfieldlesite.fr/forum/stk/ j'obtiens le message suivant :

Capture.JPG


Lorsque je me déconnecte du forum, j'obtiens :

Capture2.JPG
(19.24 Kio) Téléchargé 243 fois


Où ai-je fais une erreur ?
Je n'ose pas lancer le pack complet phpBB3.1.x avant d'avoir nettoyer ma base.

Merci d'avance. /Gérard
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44

Re: Erreur générale lors du lancement de STK

Nouveau messagepar Skouat » 02 Jan 2017 à 13:23

Bonjour,

C'est étrange le fait que le forum cherche les fichiers de langues dans ./language/en/en ou ./language/fr/fr.

Pouvez-vous tester de copier le contenu de ./language/en/ dans ./language/en/en ?

--- Edit ---

Je parle des fichiers de langues stockés dans le répertoire de STK.

--- Edit : 12h30 ---
A priori vos fichiers de langues de STK sont déjà dans ces sous-répertoires. Donc faites l'inverse, remontés les fichiers dans le répetoire parent.
Skouat
Traducteur
Traducteur
 
Messages: 13783
Enregistré le: 02 Avr 2008 à 20:47

Re: Erreur générale lors du lancement de STK

Nouveau messagepar Leon73 » 02 Jan 2017 à 13:35

Pas mieux. Voila le message que j'obtiens (juste la première ligne si je ne suis pas connecté dans un autre onglet de Firefox) :

Capture3.JPG
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44

Re: Erreur générale lors du lancement de STK

Nouveau messagepar Skouat » 02 Jan 2017 à 14:12

Bonjour,

Si je vais dans http://www.royalenfieldlesite.fr/forum/stk/language/fr/, il est possible de voir un sous répertoire nommé fr (idem pour en)
Ce qui n'est pas normal.

D'où le message d'erreur de votre dernière capture, car il est attendu un fichier "common.php" à la racine du répertoire fr et en
Skouat
Traducteur
Traducteur
 
Messages: 13783
Enregistré le: 02 Avr 2008 à 20:47

Erreur générale lors du lancement de STK

Nouveau messagepar Leon73 » 02 Jan 2017 à 14:29

OK, ça fonctionne maintenant.
En fait, j'avais copié le répertoire "fr" et non son contenu.
Merci de votre aide :)
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44

Re: Erreur générale lors du lancement de STK

Nouveau messagepar Leon73 » 02 Jan 2017 à 18:15

Bon, je ne comprends plus. Ça a fonctionné une fois puis j'ai voulu remettre tout ça à l'endroit à partir des fichiers zip et impossible de retrouver un fonctionnement normal.
Voilà ma config :

Capture5.JPG

Le fichier common.php est bien à la racine du repertoire "fr". Ce répertoire "fr" à la même structure que le répertoire "en". Ce qui est conforme à la doc :

Capture6.JPG

Mais j'obtiens un message d'erreur Language file ./language/fr/fr/common.php couldn't be opened.
Ce qui est étrange et pour moi totalement incompréhensible, c'est que j'obtiens dans le message d'erreur soit un /fr/fr soit un /en/en soit un /fr/en, suivant que je sois connecté ou non dans un autre onglet de Firefox.
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44

Re: Erreur générale lors du lancement de STK

Nouveau messagepar Skouat » 02 Jan 2017 à 20:02

Donc on en revient à mon 1er message.
Hide
Skouat a écrit:Pouvez-vous tester de copier le contenu de ./language/en/ dans ./language/en/en ?

Idem pour fr vers fr/fr.

Ce n'est en rien normal, mais c'est juste pour voir si la situation se débloque.
Skouat
Traducteur
Traducteur
 
Messages: 13783
Enregistré le: 02 Avr 2008 à 20:47

Re: Erreur générale lors du lancement de STK

Nouveau messagepar Leon73 » 02 Jan 2017 à 20:24

Ça fonctionne. Je ne touche plus à rien ;)

Voilà mon arborescence :
Capture7.JPG


Bon, ceci dit, si vous désirez que je fasse un essai, n'hésitez pas.

Merci du coup de main :)
Leon73
Posteur néophyte
Posteur néophyte
 
Messages: 29
Enregistré le: 05 Mai 2015 à 09:44


Connexion  •  M’enregistrer

cron