Modification des conditions d’utilisation

[Réglé] Parse error - Modification des conditions d’utilisation

[Réglé] Parse error

Nouveau messagepar Tarzag » 22 Juin 2014 à 14:38

Bonjour à toutes et tous,

Avant de commencer voici les paramètres
La version de votre forum: PhpBB 3.0.12
Le nom de votre hébergeur: Free
Style de votre forum : Prosilver
Il y a quelques MODs instlallés en manuel mais tout est validée au fur et à mesure et fait l'objet d'une sauvegarde :mrgreen:

http://corvetteadn.free.fr (Le forum n'est pas encore ouvert au public)
Utilisateur : Test
Mot de passe : motdepasse


Voici l'erreur que j'obtiens une fois dans l'ACP/Onglet Sytème et que je veux accéder à "Modification des conditions d'utilisation"

Parse error: syntax error, unexpected T_ARRAY, expecting '&' or T_VARIABLE or T_CONST in /mnt/159/sdb/9/d/corvetteadn/includes/functions_terms.php on line 20

(Le fichiers functions_terms.php est fourni avec le MOD )


Par avance merci
Thierry
Dernière édition de Tarzag le 29 Juin 2014 à 19:21
Tarzag
Posteur néophyte
Posteur néophyte
 
Messages: 66
Enregistré le: 17 Mai 2014 à 10:57
Localisation: Boulogne S/Mer

Re: Parse error

Nouveau messagepar Zoddo » 29 Juin 2014 à 00:22

Flûte. Incompatibilité PHP 4.

Deux solutions (une seule des deux est requise) :
  • Ajoutez cette ligne dans le .htaccess chez free pour activer php 5
    Code: Tout sélectionner
    php 1

  • Dans le fichier includes/functions_terms.php, à la ligne 20 :
    Code: Tout sélectionner
    function terms_update($lang, array $sql_ary)      
    retirez le mot clé array.
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 6539
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: Parse error

Nouveau messagepar Tarzag » 29 Juin 2014 à 19:21

Cc Zoddo

J'ai utilisé la première solution
J'avais une crainte vise à vis de Quick Title Edition qui était patché pour fonctionner avec des versions de php inférieur à la 5.20
Bha non ça vas je suis passé de PHP v4.30 à v5.1.3RC4-dev
Merci
Tarzag
Posteur néophyte
Posteur néophyte
 
Messages: 66
Enregistré le: 17 Mai 2014 à 10:57
Localisation: Boulogne S/Mer


Connexion  •  M’enregistrer

cron