Quick Title Edition

[Réglé] trim() expects parameter 1 to be string array given - Quick Title Edition

[Réglé] trim() expects parameter 1 to be string array given

Nouveau messagepar chrisBT » 12 Avr 2014 à 10:21

Bonjour a tous
Voila j'ai un message d'erreur lorsque je veux modifier ou créer un forum via l'admin, le bug vient à priori de QTE
message d'erreur
lignes concernées

le version de qte est 1.2.1 installé via AutoMOD.
Manque t il quelque chose?
D'avance merci
Dernière édition de chrisBT le 03 Mai 2014 à 13:56
Forum phpBB 3.0.12 hébergé par 1and1
chrisBT
Posteur néophyte
Posteur néophyte
 
Messages: 25
Enregistré le: 15 Mar 2009 à 12:16

Re: message d'erreur

Nouveau messagepar Steph » 12 Avr 2014 à 13:20

Salut,

Vu que tu es passé par AutoMOD je te conseille de vérifier l'installation manuellement car soit du code s'est placé au mauvais endroit soit il y avait un conflit.

Et au passage un titre plus explicite serait préférable pour les autres lors d'une recherche avec le même souci
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17622
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: message d'erreur

Nouveau messagepar chrisBT » 13 Avr 2014 à 09:26

J'ai tout re vérifié manuellement, effectivement il y avait 2 erreurs mais le problème persiste (même après vidange du cache...). Comment peut on savoir si il y a conflit?
Merci
Forum phpBB 3.0.12 hébergé par 1and1
chrisBT
Posteur néophyte
Posteur néophyte
 
Messages: 25
Enregistré le: 15 Mar 2009 à 12:16

Re: message d'erreur Php Debug

Nouveau messagepar Skouat » 13 Avr 2014 à 19:39

Bonjour,

La vidange ce n'est pas sur phpBB :roll:
Eventuellement sur un moteur :mrgreen:

Pourquoi installer QTE 1.2.1 (qui est prévu pour phpBB 3.0.11) alors que la version 1.2.2 est dispo sur ce forum.
Mais bon... quitte à installer QTE autant installer la version 1.2.5 disponible chez phpBB.com

Normalement, la version 1.2.5 ne devrait pas tarder à arriver sur ce forum.

A+ :wink:
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: message d'erreur Php Debug

Nouveau messagepar ABDev » 13 Avr 2014 à 19:51

Bonsoir,
Le hic sur la seconde capture, c'est qu'on ne voit que le code du MOD. On ne voit ni les dix lignes précédentes, ni les dix suivantes.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15689
Enregistré le: 12 Mai 2005 à 22:54

Re: message d'erreur Php Debug

Nouveau messagepar chrisBT » 19 Avr 2014 à 22:04

Hide
Skouat a écrit:Pourquoi installer QTE 1.2.1 (qui est prévu pour phpBB 3.0.11) alors que la version 1.2.2 est dispo sur ce forum.
Mais bon... quitte à installer QTE autant installer la version 1.2.5 disponible chez phpBB.com

Normalement, la version 1.2.5 ne devrait pas tarder à arriver sur ce forum.

A+ :wink:
En faite, il y a assez longtemps que la v1.2.1 est installée... et vu que je n'avais pas eu besoin de modifier de forum je ne m'étais pas aperçu du probleme plus tôt.

Pour mettre la nouvelle version, dois je désinstallé la v1.2.1?

Hide
ABDev a écrit:Bonsoir,
Le hic sur la seconde capture, c'est qu'on ne voit que le code du MOD. On ne voit ni les dix lignes précédentes, ni les dix suivantes.
je vais refaire une capture d'écran.
Forum phpBB 3.0.12 hébergé par 1and1
chrisBT
Posteur néophyte
Posteur néophyte
 
Messages: 25
Enregistré le: 15 Mar 2009 à 12:16

Re: message d'erreur Php Debug

Nouveau messagepar Steph » 19 Avr 2014 à 23:44

Salut,

Hide
chrisBT a écrit:Pour mettre la nouvelle version, dois je désinstallé la v1.2.1?


Non inutile puisque les instructions de mise à jour du MOD se trouvent dans l'archive :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17622
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: message d'erreur Php Debug

Nouveau messagepar Skouat » 20 Avr 2014 à 00:40

Bonjour,

Hide
chrisBT a écrit:
Hide
ABDev a écrit:Bonsoir,
Le hic sur la seconde capture, c'est qu'on ne voit que le code du MOD. On ne voit ni les dix lignes précédentes, ni les dix suivantes.
je vais refaire une capture d'écran.

Ou le mieux reste de mettre en lien le contenu du fichier concerné.
Un capture c'est jolie, mais ça limite un peu les analyses.
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: message d'erreur Php Debug

Nouveau messagepar chrisBT » 20 Avr 2014 à 09:07

Hide
Skouat a écrit:Ou le mieux reste de mettre en lien le contenu du fichier concerné.


lien fichier acp_forum

EDIT : par contre chose bizarre lorsque je fais détail sur QTE voila ce qu'il m'affiche
Code: Tout sélectionner
Quick Title Edition Version: 1.2.0 Chemin: ./../store/mods/qte_1_2_1/install.xml
1.2.0 ?
Forum phpBB 3.0.12 hébergé par 1and1
chrisBT
Posteur néophyte
Posteur néophyte
 
Messages: 25
Enregistré le: 15 Mar 2009 à 12:16

Re: message d'erreur Php Debug

Nouveau messagepar Skouat » 20 Avr 2014 à 19:50

Bonjour,

Les modifications sont effectivement bien en place et le fichier /adm/style/acp_forums.html est également correct.

Mets à jour le MOD en version 1.2.5.
Si tu n'a pas encore mis en service QTE, désinstalles-le et installes la dernière version, ca ira plus vite que de le mettre à jour :)
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: message d'erreur Php Debug

Nouveau messagepar ABDev » 20 Avr 2014 à 21:11

Essaie ceci please :

Code: Tout sélectionner
# #-----[ OPEN ]------------------------------------------------ # includes/acp/acp_forums.php # #-----[ FIND ]------------------------------------------------ # # This may be a partial find and not the whole line(s) # $group_ids = unserialize(trim($forum_data['hide_attr'])); # #-----[ REPLACE WITH ]---------------------------------------- # $group_ids = array_map('trim', unserialize($forum_data['hide_attr'])); # #-----[ SAVE/CLOSE ALL FILES ]-------------------------------- # # EoM
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15689
Enregistré le: 12 Mai 2005 à 22:54

Re: message d'erreur Php Debug

Nouveau messagepar Skouat » 21 Avr 2014 à 11:13

Je viens de modifier le titre du sujet afin qu'il soit plus parlant.

Ancien titre : message d'erreur Php Debug
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: trim() expects parameter 1 to be string array given

Nouveau messagepar Skouat » 26 Avr 2014 à 11:06

Des news ?
Mes MODS

Ultima-World Hébergé par phpBB-Services
Code parrainage : 1241646554
Skouat
Traducteur
Traducteur
 
Messages: 13493
Enregistré le: 02 Avr 2008 à 19:47

Re: trim() expects parameter 1 to be string array given

Nouveau messagepar chrisBT » 26 Avr 2014 à 19:38

Désolé, je n'ai pas eu le temps de regarder depuis...
Forum phpBB 3.0.12 hébergé par 1and1
chrisBT
Posteur néophyte
Posteur néophyte
 
Messages: 25
Enregistré le: 15 Mar 2009 à 12:16

Re: trim() expects parameter 1 to be string array given

Nouveau messagepar chrisBT » 28 Avr 2014 à 13:20

Hide
ABDev a écrit:Essaie ceci please :

Si j’essaie ça voila ce qu'il affiche

Code: Tout sélectionner
[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_forums.php on line 674: unserialize() expects parameter 1 to be string, array given [phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_forums.php on line 674: array_map(): Argument #2 should be an array [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_attributes.php on line 654: in_array() expects parameter 2 to be array, null given [phpBB Debug] PHP Warning: in file [ROOT]/adm/index.php on line 150: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887) [phpBB Debug] PHP Warning: in file [ROOT]/adm/index.php on line 152: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887) [phpBB Debug] PHP Warning: in file [ROOT]/adm/index.php on line 153: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887) [phpBB Debug] PHP Warning: in file [ROOT]/adm/index.php on line 154: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)


Hide
Skouat a écrit:Mets à jour le MOD en version 1.2.5.
Si tu n'a pas encore mis en service QTE, désinstalles-le et installes la dernière version, ca ira plus vite que de le mettre à jour :)
Cela fait quelque mois qu'il est en place
Forum phpBB 3.0.12 hébergé par 1and1
chrisBT
Posteur néophyte
Posteur néophyte
 
Messages: 25
Enregistré le: 15 Mar 2009 à 12:16

Suivante

Connexion  •  M’enregistrer

cron