Quick Title Edition

[Réglé] [Quick Title Edition 1.2.5] Problemes d'installation - Quick Title Edition

[Réglé] [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar cotp » 27 Aoû 2015 à 16:11

http://www.phpbb-fr.com/customise/db/mod/qte/
[Quick Title Edition] version 1.2.5 sur phpBB 3.0.13-PL1 premodseo

Bonjour à tous et merci pour ce mod !

J'ai un souci suite à l'installation sur mon forum de [Quick Title Edition] et j'aimerai savoir si vous pourriez avoir la gentillesse de m'aider à débugger d'où vient mon erreur ?

Comme il s'agissait de la premod de phpbb seo j'ai bien suivi vos conseils pour trouver et remplacer les lignes différentes (lues sur le forum)

L'installation s'est bien passé et le mod est activé.

Cependant 2 problèmes subsistent

1) Quand je veux créer un attribut de sujet j'ai l'erreur suivante

Code: Tout sélectionner

[phpBB Debug] PHP Warning: in file [ROOT]/includes/acp/acp_attributes.php on line 576: Invalid argument supplied for foreach()



2) Mon panneau de modération est planté (page blanche)

Le reste du site semble fonctionner correctement

En attendant vos réponses je vais de ce pas revoir toutes mes lignes d'install voir si j'ai bien tout copié au bon endroit :)

A bientot,

Bien amicalement

Cotp
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar ABDev » 28 Aoû 2015 à 07:27

Bonjour,
Il faudrait me donner plus de détails quand vous avez le message.
Faites-moi une capture des données que vous tentez d'enregistrer, permissions comprises.

Concernant le MCP, il faut revoir l'installation.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15695
Enregistré le: 12 Mai 2005 à 23:54

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar cotp » 29 Aoû 2015 à 01:36

Bonjour ABDev et merci de votre réponse,

En fait j'essayais juste d'ajouter un attribut dans le back office, quand je clique sur le bouton "Ajouter un nouvel attribut" (cf fichier joint) j'obtiens cette pahe d'erreur sur la page /adm/index.php?i=attributes&mode=manage

Pour le panneau de moderation, j'ai une page blanche quand j'essaye d'y accéder...

Quel fichier regarder en priorité pour deboguer ?

Merci par avance

Cotp
Fichiers joints
attributs.JPG
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar ABDev » 29 Aoû 2015 à 13:01

Ouvrez le fichier includes/functions_attributes.php
Effectuez les modifications qui suivent :

Remplacer :

Code: Tout sélectionner
        if ( ($this->attr $cache->get('_attr')) === false )
        { 

par :

Code: Tout sélectionner
//        if ( ($this->attr = $cache->get('_attr')) === false )
//        { 

Et remplacer :

Code: Tout sélectionner
            $cache->put('_attr'$this->attr);
        } 

par :

Code: Tout sélectionner
//            $cache->put('_attr', $this->attr);
//        } 

Tentez ensuite de créer un attribut pour voir.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15695
Enregistré le: 12 Mai 2005 à 23:54

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar cotp » 29 Aoû 2015 à 14:18

Bonjour ABDev,

J'ai bien fait les modifs ci dessus mais j'ai toujours le meme message d'erreur quand je veux créer un attribut...

Je dois avoir une autre erreur quelque part :/

Pourriez vous m'envoyer un exemple d'attribut en SQL je pourrais essayer de l'intégrer par PHPMYADMIN et voir s'il apparait bien sur le frontend ?

Merci par avance pour votre aide

Cotp
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar ABDev » 29 Aoû 2015 à 14:37

Voilà :

Code: Tout sélectionner
INSERT INTO phpbb_topics_attr (attr_id, attr_type, attr_name, left_id, right_id, attr_img, attr_date, attr_colour, attr_user_colour, attr_desc, attr_auths) VALUES(1, 0, 'QTE_SOLVED', 1, 2, '', 'j/m', '', 0, '', '[{"forums_ids":[],"groups_ids":[],"author":false}]');
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15695
Enregistré le: 12 Mai 2005 à 23:54

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar cotp » 30 Aoû 2015 à 11:06

Hide
ABDev a écrit:Voilà :

Code: Tout sélectionner
INSERT INTO phpbb_topics_attr (attr_id, attr_type, attr_name, left_id, right_id, attr_img, attr_date, attr_colour, attr_user_colour, attr_desc, attr_auths) VALUES(1, 0, 'QTE_SOLVED', 1, 2, '', 'j/m', '', 0, '', '[{"forums_ids":[],"groups_ids":[],"author":false}]');


Merci ABDev ! :)

ça m'a permis de voir une différence, mes tables s'appellent phpbb3 et pas phpbb

ainsi j'avais la table phpbb3_topics_attr au lieu de phpbb_topics_attr

Est-ce que je dois modifier des fichiers en conséquence ou pas ?

Cotp
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar Zoddo » 30 Aoû 2015 à 11:24

Bonjour,

Non, pas de modification à faire dans phpBB, c'est déjà gérer nativement (le préfixe des noms de table est stocké dans le fichier config.php).
[Doc] Installer une extension - [Extension] Post Models - [Recrutement] Équipe des Extensions
Si vous considérez votre requête comme résolue, merci d'ajouter l'attribut de sujet [Réglé]
Zoddo
Equipe site
Equipe site
 
Messages: 6572
Enregistré le: 16 Mar 2011 à 18:44
Localisation: Laval / Le Mans

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar cotp » 30 Aoû 2015 à 13:45

Hide
Zoddo a écrit:Bonjour,

Non, pas de modification à faire dans phpBB, c'est déjà gérer nativement (le préfixe des noms de table est stocké dans le fichier config.php).


Merci Zoddo pour ta réponse.

Sinon j'ai revu mes fichiers, le panneau de modération est réparé (je pense que c'était dû à une modif qui n'était pas passée par ftp).

Je peux également créer des attributs (ça venait sans doute d'une incompatibilité avec un ancien mod que j'ai désactivé)

Mon problème est presque résolu, j'ai un dernier souci, esthetique cette fois, j'aimerai faire apparaitre l'attribut du sujet au tout début du nom du sujet topic et pas en fin dans la liste viewforum.

Pour l'instant j'ai fait une capture de ce que ça donne en fichier joint.

Voilà ce vers quoi j'aimerai aboutir:

[Attribut] Nom du sujet

Merci par avance pour votre aide

Cotp
Fichiers joints
attributend.JPG
attributend.JPG (10.61 Kio) Vu 159 fois
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar ABDev » 30 Aoû 2015 à 14:21

Ce que vous demandez, c'est la présentation par défaut, donc vous vous êtes planté dans la phase d'installation sur le fichier viewforum_body.html de votre style.
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15695
Enregistré le: 12 Mai 2005 à 23:54

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar cotp » 30 Aoû 2015 à 14:58

Hide
ABDev a écrit:Ce que vous demandez, c'est la présentation par défaut, donc vous vous êtes planté dans la phase d'installation sur le fichier viewforum_body.html de votre style.


Ah oooops Merci ABDev, je vais regardé si j'ai fais une bourde dans le fichier :oops:

Sinon je ne sais pas si c'est lié à l'installation du mod ou à la désinstallation de l'ancien mod mais quand je clique sur forum dans le panneau admin j'ai ce message d'erreur:

Code: Tout sélectionner
MODULE_NOT_ACCESS BACKTRACE FILE: (not given by php) LINE: (not given by php) CALL: msg_handler() FILE: [ROOT]/includes/functions_module.php LINE: 439 CALL: trigger_error() FILE: [ROOT]/adm/index.php LINE: 79 CALL: p_master->load_active()


Est-ce que je dois ouvrir un nouveau sujet pour ça ?

Cotp
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Quick Title Edition 1.2.5] Problemes d'installation

Nouveau messagepar ABDev » 30 Aoû 2015 à 17:41

Le message d'erreur n'est en rien lié à QTE (il est présent dans l'onglet "Messages", et vous ça se passe dans l'onglet "Forums").
Il faut donc créer un sujet dans le support de phpBB3.

PS : Évitez de citer à tout va le message précédent, ça ne sert strictement à rien !
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15695
Enregistré le: 12 Mai 2005 à 23:54

Re: [Réglé] [Quick Title Edition 1.2.5] Problemes d'installa

Nouveau messagepar cotp » 30 Aoû 2015 à 23:46

Ok c'est noté, je passe le sujet en réglé donc.

Merci encore pour votre aide

PS: désolé pour les citations (une mauvaise habitude en effet, comme un tic de langage quand j'y pense)
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Réglé] [Quick Title Edition 1.2.5] Problemes d'installa

Nouveau messagepar cotp » 01 Sep 2015 à 22:54

Bonjour ABDev,

Je viens de m'apercevoir que mes profils membres n'étaient plus accessible j'ai le message d'erreur suivant:

Code: Tout sélectionner
SQL ERROR [ mysql4 ] Unknown column 'topic_attr_id' in 'field list' [1054] SQL SELECT topic_attr_id, topic_attr_user, topic_attr_time, topic_id, COUNT(post_id) AS num_posts FROM phpbb3_posts WHERE poster_id = 4 AND post_postcount = 1 AND (post_approved = 1 OR forum_id IN (2, 3, 4, 5, 7, 8, 9, 11, 14, 16, 18, 19, 20, 21, 22, 23, 24, 25, 27, 28, 31, 32, 33, 36, 37, 39, 40, 41, 43, 44, 46, 49, 50, 52, 54, 56, 57, 58, 60, 61, 62, 63, 64, 65, 67, 69, 70, 72, 74, 76, 77, 78, 79, 80, 81, 95, 96, 98, 99, 100, 101, 102, 103, 104, 107, 108, 109, 110, 111, 113, 114, 115, 116, 117, 118, 119, 120, 121, 122, 123, 124, 125, 128, 129, 136, 145, 146, 147, 148, 149, 150, 152, 153, 154, 165, 174, 177, 179, 180, 181, 186, 187, 189, 191, 192, 193, 194, 195, 196, 197, 198, 199, 200)) GROUP BY topic_id ORDER BY num_posts DESC LIMIT 1 BACKTRACE FILE: (not given by php) LINE: (not given by php) CALL: msg_handler() FILE: [ROOT]/includes/db/dbal.php LINE: 757 CALL: trigger_error() FILE: [ROOT]/includes/db/mysql.php LINE: 193 CALL: dbal->sql_error() FILE: [ROOT]/includes/db/mysql.php LINE: 240 CALL: dbal_mysql->sql_query() FILE: [ROOT]/includes/db/dbal.php LINE: 170 CALL: dbal_mysql->_sql_query_limit() FILE: [ROOT]/includes/functions_display.php LINE: 1199 CALL: dbal->sql_query_limit() FILE: [ROOT]/memberlist.php LINE: 585 CALL: display_user_activity()


comme il est question de "Unknown column 'topic_attr_id' in 'field list' [1054]" je me dis que ça doit venir du mod attribut...

Une idée de ce que je pourrai vérifier pour régler le problème ?

Merci par avance

Cotp
Avatar de l’utilisateur
cotp
Posteur expérimenté
Posteur expérimenté
 
Messages: 396
Enregistré le: 20 Juil 2005 à 10:03

Re: [Réglé] [Quick Title Edition 1.2.5] Problemes d'installa

Nouveau messagepar ABDev » 02 Sep 2015 à 06:05

J'ignore comment vous avez fait l'installation, mais elle n'a pas été réalisée correctement ...
Le fichier db_update.php a bien été exécuté ?
Pour se payer le luxe d'être feignant, il faut sans cesse faire travailler ses méninges ! (Korben)

On clique sur le bouton Répondre plutôt que le bouton Citer ...
Un problème avec une extension ? Pas de lien vers celle-ci ? Sujet ignoré !
Avatar de l’utilisateur
ABDev
Programmationateur
Programmationateur
 
Messages: 15695
Enregistré le: 12 Mai 2005 à 23:54

Suivante

Connexion  •  M’enregistrer

cron