Attention: l’auteur de cette contribution n’assure pas le support.

Advanced BBCode Box 3.1

[Réglé] Erreur lors de l'aperçu - Advanced BBCode Box 3.1

[Réglé] Erreur lors de l'aperçu

Nouveau messagepar tablettechinoise » 12 Mai 2016 à 14:33

Forum : http://www.tablette-chinoise.net/forum
Forum de test : http://88.181.151.128:8080/
Version Forum de test : phpbb 3.1.9

Bonjour,

Suis en phase de test et validation pour une migration de phpbb 3.0.12 vers phpbb 3.1.9
Etat d'avancement :
Migration de la base OK
Mise en place du forum de test sous 3.1.9 OK
Forum de test fonctionnel.


J'ai installé l'extension Advanced BBCode Box qui est en version 3.1.2 d'ailleurs ce jour ;)

Si je réponds, ou je crée un nouveau post, je me retrouve sans souci avec l'affichage du module Advanced BBCode Box pour écrire.

Mon souci :
Lorsque je clique sur Aperçu sans aucun apport de mise en page et donc laissant du texte brut, là pas de souci.
Par contre, quand j'apporte une mise en page, prenons l'exemple de mettre en gras, et que je clique sur Aperçu, là j'ai un souci : Déja le bouton Aperçu se retrouve avec des hiéroglyphes mais aussi le BBcode n'est pas pris en charge.

Mais surtout, tout en haut je me retrouve avec une multitude d'erreur php :

Code: Tout sélectionner
[phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/message_parser.php on line 84: preg_match(): No ending delimiter '.' found [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5312: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3925) [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5312: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3925) [phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 5312: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3925)



En regardant aussi les icones de mise en page, il en manque aussi d'ailleurs et son remplacé par du texte...

Merci pour votre retour

Tof
tablettechinoise
Posteur expérimenté
Posteur expérimenté
 
Messages: 343
Enregistré le: 21 Mar 2013 à 20:28

Re: Erreur lors de l'aperçu

Nouveau messagepar soda » 12 Mai 2016 à 14:48

Tu n'aurais pas un bbcode en double ?
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 341
Enregistré le: 25 Déc 2006 à 11:55
Localisation: Sur mon cheval blanc

Re: Erreur lors de l'aperçu

Nouveau messagepar tablettechinoise » 12 Mai 2016 à 14:49

Tu veux dire quoi ? J'ai rien fait d'autres que d'installer l'extension
tablettechinoise
Posteur expérimenté
Posteur expérimenté
 
Messages: 343
Enregistré le: 21 Mar 2013 à 20:28

Re: Erreur lors de l'aperçu

Nouveau messagepar FoFa » 12 Mai 2016 à 14:52

Hello,

Certes, tu as installé l'extension. Mais avant, en 3.0.x, tu n'avais pas deux fois le même BBCode ?

Peut-être une capture d'écran de ta page des BBCodes pourrait nous éclairer :wink:
Après l'assassinat de mon ordinateur, je reviens progressivement vers vous...
FoFa
Resp. des supporters
Resp. des supporters
 
Messages: 10366
Enregistré le: 15 Nov 2008 à 18:04
Localisation: Auxonne

Re: Erreur lors de l'aperçu

Nouveau messagepar tablettechinoise » 12 Mai 2016 à 15:01

Voici un screenshot :

Image

Lien : http://88.181.151.128:8080/BUG_IMAGE/Bug_BBCODE.png

Vérification faite sous Phpbb3.0.12, et je n'ai pas de doublon.

Toutefois, dans l'outil STK, j'ai trouvé une option qui était : Réanalyser le BBCode Au cas ou, je vous passe cet info.
tablettechinoise
Posteur expérimenté
Posteur expérimenté
 
Messages: 343
Enregistré le: 21 Mar 2013 à 20:28

Re: Erreur lors de l'aperçu

Nouveau messagepar soda » 12 Mai 2016 à 15:03

C'est sous phpBB 3.1.x qu'il faut regarder, car si l'extension rajoute un bbcode que tu avais déjà avant, cela pourrait expliquer le soucis
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 341
Enregistré le: 25 Déc 2006 à 11:55
Localisation: Sur mon cheval blanc

Re: Erreur lors de l'aperçu

Nouveau messagepar tablettechinoise » 12 Mai 2016 à 15:05

C'est bien phpbb 3.1.9 que vous avez en screenshot

Et pour info, sous phpbb 3.0.12, dans BBCode, je n'avais que ceci :

Rebours
SAV
aide_nul
debutant
merci_don
no_sms
paypal
present
regle
resolu
verrou
tablettechinoise
Posteur expérimenté
Posteur expérimenté
 
Messages: 343
Enregistré le: 21 Mar 2013 à 20:28

Re: Erreur lors de l'aperçu

Nouveau messagepar soda » 12 Mai 2016 à 15:15

Je ne parlais pas de la capture, mais de ça:
Hide
tablettechinoise a écrit:Vérification faite sous Phpbb3.0.12, et je n'ai pas de doublon.


Mais il y a des choses étranges sur ta capture, les bbcode standards ne devraient pas y figurer, et des bbcodes que tu n'avais pas sous phpbb 3.0 et qui ne sont pas installés par cette extension sont apparus (listo ? listb ?)
Appelez moi..... Ismaël

phpBB-Services.com: L'hébergement et l'assistance de votre forum phpBB en toute tranquillité.
soda
Posteur expérimenté
Posteur expérimenté
 
Messages: 341
Enregistré le: 25 Déc 2006 à 11:55
Localisation: Sur mon cheval blanc

Re: Erreur lors de l'aperçu

Nouveau messagepar tablettechinoise » 12 Mai 2016 à 15:23

Oui effectivement, en installation un phpbb 3.1.9 de base, j'ai vu que c'etait autrement dans le bbcode...

Du coup j'ai désactivé Advanced BBCode Box 3.1, supprimé l'ensemble des bbcodes et tout est rentré dans l'ordre...

Merci en tout cas pour m'avoir mis sur la voie ;)

Tof
tablettechinoise
Posteur expérimenté
Posteur expérimenté
 
Messages: 343
Enregistré le: 21 Mar 2013 à 20:28


Connexion  •  M’enregistrer

cron