Attention: l’auteur de cette contribution n’assure pas le support.

Advanced BBCode Box 3.1

[Réglé] Disparition d'un bouton lors de l'activation - Advanced BBCode Box 3.1

[Réglé] Disparition d'un bouton lors de l'activation

Nouveau messagepar pboulanger » 27 Sep 2015 à 09:44

Bonjour

Nous utilisons l'extension "Module hosting image EmpreintesDuWeb" qui ajoute un "bouton" BBCode porur atciver une popup

Quand j'active Advanced BBCode Box 3.1 ce bouton disparaît ....

Nous avons 36 boutons en mode texte
Image

et 38 en mode "graphique"
Image

Mais aucun des "graphiques" correspond au bouton "Héberger une image"

Comment faire pour le garder visible avec l'extension ?

Notre forum http://www.myasthenie.com en 3.1.6

Je peux fournir un accès admin si nécessaire ....

Merci d'avance de votre aide

Bonne journée
Amicalement,

Pierre
pboulanger
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 20 Sep 2011 à 15:26
Localisation: Oise France

Re: Disparition d'un bouton lors l'activation de cette exten

Nouveau messagepar Steph » 30 Sep 2015 à 10:27

Salut,

Je me suis penché sur le problème et à-priori mon extension ne sera pas la seule a avoir ce souci du moins pour toutes celle qui utiliserons le même "event" que moi, car en fait le code d'origine est caché via un "displat: none" et est remaplcé par le code de Advanced BBCode Box 3.1.

Pour résoudre le problème dans l'attente ouvre le fichier ext\vse\abbc3\styles\all\template\abbc3_posting_buttons.html et trouve ce code

Code: Tout sélectionner
<!-- END custom_tags -->


Et ajoute ceci juste en dessous

Code: Tout sélectionner
<!-- IF (S_EDW_IMAGEHOSTING_ACTIVE_USER and not S_EDW_IMAGEHOSTING_ACTIVE_IFRAME) and S_EDW_IMAGEHOSTING_ACTIVE_POPUP --><input type="button" class="button2" name="imagehosting" value="{L_EDW_IMAGEHOSTING_TITLE}" onclick="window.open(<!-- IF S_EDW_IMAGEHOSTING_OTHER_HOSTING -->'{U_ANOTHER_HOSTER}'<!-- ELSE -->'http://images.empreintesduweb.com/popup/id-{EDW_IMAGEHOSTING_ID}/?url=http://' + escape(window.location.hostname)<!-- ENDIF -->, 'imagehosting', 'resizable=yes,width={EDW_IMAGEHOSTING_WIDTH},height={EDW_IMAGEHOSTING_HEIGHT}');return false;" title="{L_EDW_IMAGEHOSTING_TITLE_EXPLAIN}" /><!-- ENDIF -->


Cela permettra de faire apparaitre le bouton et cela tiendra compte de la désactivation de la popup si plus tard tu veux changer.

Par contre, a chaque mise à jour de l'extension il faudra refaire la modification, mais rien d'insurmontable
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17274
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Disparition d'un bouton lors l'activation de cette exten

Nouveau messagepar pboulanger » 30 Sep 2015 à 10:52

Bonjour Steph,

Merci pour ton aide toujours aussi efficace ...

Modification faite et opérationnelle

bonne journée
Amicalement,

Pierre
pboulanger
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 20 Sep 2011 à 15:26
Localisation: Oise France

Re: Disparition d'un bouton lors l'activation de cette exten

Nouveau messagepar Steph » 30 Sep 2015 à 10:58

Ce n'est qu'une rustine :wink:

N'oublie pas de passer le sujet en réglé
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17274
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France

Re: Disparition d'un bouton lors l'activation de cette exten

Nouveau messagepar pboulanger » 30 Sep 2015 à 11:16

Steph

Euh, je n'ai pas la possibilité de mettre ce sujet en Réglé
Amicalement,

Pierre
pboulanger
Apprenti-posteur
Apprenti-posteur
 
Messages: 165
Enregistré le: 20 Sep 2011 à 15:26
Localisation: Oise France

Re: Disparition d'un bouton lors l'activation de cette exten

Nouveau messagepar Steph » 30 Sep 2015 à 12:01

Oui dans cette partie du site il faut l'ajouter manuellement au titre, je le fait pour toi :wink:
Avatar de l’utilisateur
Steph
Administrateur
Administrateur
 
Messages: 17274
Enregistré le: 29 Déc 2008 à 15:48
Localisation: Alsace / Bas-Rhin / France


Connexion  •  M’enregistrer

cron